zoukankan      html  css  js  c++  java
  • 问题 B: c#计算长方形的面积(继承问题)

    题目描述

    根据给出的代码,补全缺失的代码,输入两个数字为长方形的长和宽,从而得出长方形的面积。


    using System;
    namespace InheritanceApplication
    {
       class Shape 
       {
          public void setWidth(int w)
          {
             width = w;
          }
          public void setHeight(int h)
          {
             height = h;
          }
          protected int width;
          protected int height;
       }
    /****************/
    编写此处代码,并只提交此处代码
    /****************/
       
       class RectangleTester
       {
          static void Main(string[] args)
          {
             Rectangle Rect = new Rectangle();
            int width = int.Parse(Console.ReadLine());
              int height =int.Parse(Console.ReadLine());
             Rect.setWidth(width);
             Rect.setHeight(height);
             Console.WriteLine("总面积: {0}",  Rect.getArea());
             Console.ReadKey();
          }
       }
    }

    输入

    3 5

    输出

    15

    样例输入

    5
    7

    样例输出

    35

    using System;
    namespace InheritanceApplication
    {
        class Shape
        {
            public void setWidth(int w)
            {
                width = w;
            }
            public void setHeight(int h)
            {
                height = h;
            }
            protected int width;
            protected int height;
        }
    
        class Rectangle:Shape
        {
            public int getArea()
            {
                return width * height;
            }
        }
    
        class RectangleTester
        {
            static void Main(string[] args)
            {
                Rectangle Rect = new Rectangle();
                int width = int.Parse(Console.ReadLine());
                int height = int.Parse(Console.ReadLine());
                Rect.setWidth(width);
                Rect.setHeight(height);
                Console.WriteLine("总面积: {0}", Rect.getArea());
                Console.ReadKey();
            }
        }
    }
    

      

    提交部分

        class Rectangle:Shape
        {
            public int getArea()
            {
                return width * height;
            }
        }
    

      

  • 相关阅读:
    UVA 10564 Paths through the Hourglass DP
    HDU 3397 Sequence operation 线段树 成段更新 区间合并
    HDU 3308 LCIS 线段树 单点更新+区间合并
    POJ 3667 Hotel 线段树 区间合并
    UVALive 3942 Remember the Word Tire+DP
    POJ 1703 Find them, Catch them
    UVA 1366 Martian Mining DP
    UVA 1456 Cellular Network 贪心+DP
    UVA 11573 Ocean Currents
    【ACM】hdu_zs1_1003_放大的X _201307271557
  • 原文地址:https://www.cnblogs.com/mjn1/p/12618940.html
Copyright © 2011-2022 走看看