zoukankan      html  css  js  c++  java
  • 1658: Easier Done Than Said?

    1658: Easier Done Than Said?

    Time Limit: 1 Sec  Memory Limit: 64 MB
    Submit: 15  Solved: 12
    [Submit][Status][Web Board]

    Description

    Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember. FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules: It must contain at least one vowel. It cannot contain three consecutive vowels or three consecutive consonants. It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'. (For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

    Input

    The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

    Output

    For each password, output whether or not it is acceptable, using the precise format shown in the example.

    Sample Input

    a
    tv
    ptoui
    bontres
    zoggax
    wiinq
    eep
    houctuh
    end

    Sample Output

    <a> is acceptable.
    <tv> is not acceptable.
    <ptoui> is not acceptable.
    <bontres> is not acceptable.
    <zoggax> is not acceptable.
    <wiinq> is not acceptable.
    <eep> is acceptable.
    <houctuh> is acceptable.


    #include<stdio.h>
    #include<string.h>
    
    int yuanyin(char c)
    {
        if(c=='a'||c=='e'||c=='i'||c=='o'||c=='u')    return 1;
        return 0;
    }
    
    int is_yuanyin(char a[])
    {
        int i,len=strlen(a);
        for( i=0; i<len; i++)
            if( yuanyin(a[i]) )return 1;
        return 0;
    }
    
    int lianxu(char a[])
    {
        int i,len = strlen(a);
        for(i=0;i<len;i++)
        {
            if ( i+2 < len && yuanyin(a[i]) && yuanyin(a[i+1]) && yuanyin(a[i+2]))
                return 0;
            if ( i+2 < len && !yuanyin(a[i]) && !yuanyin(a[i+1]) && !yuanyin(a[i+2]))
                return 0;
        }
        return 1;
    }
    
    int xiangtong(char a[])
    {
        int i, len=strlen(a);
        for( i=0; i<len ; i++)
        {
            if(i+1<len && a[i]==a[i+1] && a[i]!='e' && a[i]!='o')
                return 0;
        }
        return 1;
    }
    
    int main()
    {
        char a[100];
        int len,i;
        while(scanf("%s",a)!=EOF){
                if( strcmp(a,"end")==0) break;
                if(is_yuanyin(a)&&lianxu(a)&&xiangtong(a))
                    printf("<%s> is acceptable.\n",a);
                else
                    printf("<%s> is not acceptable.\n",a);
        }
    
    }
    

      

  • 相关阅读:
    《陶哲轩实分析》习题10.4.3
    陶哲轩实分析定理10.1.3:导数运算的积法则和商法则
    《数学分析新讲》_张筑生,12.5节:隐函数定理(1)
    《数学分析新讲》_张筑生,12.5节:隐函数定理(1)
    《陶哲轩实分析》定理10.1.15:导数的链法则
    我的博客园的CSS和html设置
    陶哲轩实分析定理10.1.3:导数运算的积法则和商法则
    关于Eclipse中一个错误排查总结
    RMI, Dynamic Proxies, and the Evolution of Deployment
    Java垃圾回收机制浅析
  • 原文地址:https://www.cnblogs.com/mjn1/p/8436871.html
Copyright © 2011-2022 走看看