zoukankan      html  css  js  c++  java
  • hdu2637

                                                      shǎ崽 OrOrOrOrz

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3654 Accepted Submission(s): 1138
     
    Problem Description
    Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
    The problem is :
    Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .
    For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
     
    Input
    There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
     
    Output
    Output a sequence of distinct integers described above.
     
    Sample Input
    5
    1 2 3 4 5
     
    Sample Output
    5 1 4 2 3
     
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    int main()
    {
        int n,i,flag,j;
        int a[10000];
        while(cin>>n&&n)
        {        
            for(i=0;i<n;i++)
                cin>>a[i];
            sort(a,a+n);//默认升序
            flag=0;
            for(i=0,j=n-1;i<=j;i++,j--)
            {
                if(flag==0)    flag=1;
                else
                    cout<<" ";
                if(i==j) 
                    cout<<a[i];
                else 
                    cout<<a[j]<<" "<<a[i];
            }
            cout<<endl;
        }    
        return 0;
    }
  • 相关阅读:
    PHP7革新与性能优化
    git团队开发
    PHP获取机器mac代码
    js复制文字
    jquery datatable客户端分页保持
    自已编写C# DLL 绑定到unity进程进行单步调试
    ‘xxfile' Missing the class attribute 'ExtensionOfNativeClass'
    关于热更的杂记
    关于unityengine.dll, unityengine.coremodule.dll
    学到了关于服务器磁盘阵列
  • 原文地址:https://www.cnblogs.com/mm-happy/p/3807946.html
Copyright © 2011-2022 走看看