zoukankan      html  css  js  c++  java
  • 1020 Tree Traversals (25 分)(⼆叉树的遍历,后序中序转层序)

    Description

    Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

    Sample Input:

    7
    2 3 1 5 7 6 4
    1 2 3 4 5 6 7
    

    Sample Output:

    4 1 6 3 5 7 2
    

    生词

    英文 解释
    distinct 不同的
    traversal 遍历
    corresponding 相应的

    题目大意:

    给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数

    分析:

    与后序中序转换为前序的代码相仿(无须构造二叉树再进行广度优先搜索~),只不过加一个变量index,表示当前的根结点在二叉树中所对应的下标(从0开始),所以进行一次输出先序的递归过程中,就可以把根结点下标index及所对应的值存储在map<int, int> level中,map是有序的会根据index从小到大自动排序,这样递归完成后level中的值就是层序遍历的顺序~~

    如果你不知道如何将后序和中序转换为先序,请看-> https://www.liuchuo.net/archives/2090

    原文链接:https://blog.csdn.net/liuchuo/article/details/52137796

    题解

    终于把这篇在11.04就编辑的博文抄完了。。。
    学废了之后发现也不是很难,可能忘太多了觉得太陌生了,有畏惧感呜呜
    总而言之,还是要迎难而上!
    image
    image

    #include <bits/stdc++.h>
    const int maxn=50;
    using namespace std;
    struct node
    {
        int data;
        node* lchild;
        node* rchild;
    };
    int pre[maxn],in[maxn],post[maxn];
    int n;
    node* create(int postL,int postR,int inL,int inR)
    {
        if(postL>postR) return nullptr;
        node* root=new node;
        root->data=post[postR];
        int k;
        for(k=inL;k<=inR;k++){
            if(in[k]==post[postR]) break;
        }
        int numLeft=k-inL;
        root->lchild=create(postL,postL+numLeft-1,inL,k-1);
        root->rchild=create(postL+numLeft,postR-1,k+1,inR);
        return root;
    }
    int num=0;
    void BFS(node* root){
        queue<node*> q;
        q.push(root);
        while(!q.empty()){
            node* now=q.front();
            q.pop();
            printf("%d",now->data);
            num++;
            if(num<n)printf(" ");
            if(now->lchild!=nullptr) q.push(now->lchild);
            if(now->rchild!=nullptr) q.push(now->rchild);
        }
    }
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d",&post[i]);
        }
        for(int i=0;i<n;i++){
            scanf("%d",&in[i]);
        }
        node* root=create(0,n-1,0,n-1);
        BFS(root);
        return 0;
    }
    

    柳神代码(码住,以后看!)

    #include <cstdio>
    #include <vector>
    #include <map>
    using namespace std;
    vector<int> post, in;
    map<int, int> level;
    void pre(int root, int start, int end, int index) {
        if(start > end) return ;
        int i = start;
        while(i < end && in[i] != post[root]) i++;
        level[index] = post[root];
        pre(root - 1 - end + i, start, i - 1, 2 * index + 1);
        pre(root - 1, i + 1, end, 2 * index + 2);
    }
    int main() {
        int n;
        scanf("%d", &n);
        post.resize(n);
        in.resize(n);
        for(int i = 0; i < n; i++) scanf("%d", &post[i]);
        for(int i = 0; i < n; i++) scanf("%d", &in[i]);
        pre(n-1, 0, n-1, 0);
        auto it = level.begin();
        printf("%d", it->second);
        while(++it != level.end()) printf(" %d", it->second);
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15507553.html

  • 相关阅读:
    [Swift通天遁地]五、高级扩展-(2)扩展集合类型
    [Swift通天遁地]五、高级扩展-(1)快速检测设备属性:版本、类型、屏幕尺寸
    [Swift]LeetCode266.回文全排列 $ Palindrome Permutation
    [Swift]LeetCode265.粉刷房子 II $ Paint House II
    [Swift]LeetCode264.丑数 II | Ugly Number II
    [Swift通天遁地]四、网络和线程-(15)程序内购功能
    [Swift通天遁地]四、网络和线程-(14)创建一个Socket服务端
    hdu 4888 Redraw Beautiful Drawings(最大流,判环)
    【剑指offer】斐波那契序列与跳台阶
    Asp.NET之对象学习
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15507553.html
Copyright © 2011-2022 走看看