zoukankan      html  css  js  c++  java
  • 1009 Product of Polynomials (25 分)(模拟)

    This time, you are supposed to find A*B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

    Output Specification:

    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

    Sample Input

    2 1 2.4 0 3.2
    2 2 1.5 1 0.5

    Sample Output

    3 3 3.6 2 6.0 1 1.6

    分析:

    简单模拟~double类型的arr数组保存第一组数据,ans数组保存结果。当输入第二组数据的时候,一边进行运算一边保存结果。最后按照指数递减的顺序输出所有不为0的项~

    注意:

    因为相乘后指数可能最大为2000,所以ans数组最大要开到2001~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52109341

    题解

    找了半天bug,发现ans数组开了2001,,,,,
    因为ans需要把两个数组的下标相加,所以要注意这点。。。

    #include <bits/stdc++.h>
    
    using namespace std;
    double b,arr[1001],ans[2001];
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n1,n2,a,cnt=0;
        scanf("%d",&n1);
        for(int i=0;i<n1;i++){
            scanf("%d %lf",&a,&b);
            arr[a]=b;
        }
        scanf("%d",&n2);
        for(int i=0;i<n2;i++){
            scanf("%d %lf",&a,&b);
            for(int j=0;j<1001;j++){
                ans[j+a]+=arr[j]*b;
            }
        }
        for(int i=2000;i>=0;i--)
            if(ans[i]!=0) cnt++;
        printf("%d",cnt);
        for(int i=2000;i>=0;i--){
            if(ans[i]!=0) printf(" %d %.1f",i,ans[i]);
        }
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15510869.html

  • 相关阅读:
    ModbusTCP_Server之FB的建立
    ModbusTCP_Client之FB的建立
    ModbusRTU_Slave之FB的建立
    ModbusRTU_Master之FB的建立
    外部模式启动程序
    配方Recipes的程序实现过程
    socket通信实现程序
    面试题37:序列化二叉树(C++)
    面试题36:二叉搜索树与双向链表(C++)
    面试题31:栈的压入、弹出序列(C++)
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15510869.html
Copyright © 2011-2022 走看看