zoukankan      html  css  js  c++  java
  • 1019 General Palindromic Number (20 分)(回文数)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

    Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

    Input Specification:

    Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

    Output Specification:

    For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.

    Sample Input 1:

    27 2

    Sample Output 1:

    Yes
    1 1 0 1 1

    Sample Input 2:

    121 5

    Sample Output 2:

    No
    4 4 1

    生词

    英文 解释
    Palindromic Number 回文数
    palindromicity 回文
    numeral system 数制
    notation 符号

    题目大意:

    给出两个整数a和b,问十进制的a在b进制下是否为回文数。是的话输出Yes,不是输出No。并且输出a在b进制下的表示,以空格隔开~

    分析:

    将a转换为b进制形式,保存在int的数组里面,比较数组左右两端是否对称~

    注意:

    如果是0,要输出Yes和0~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52120574

    测试点2、4未过

    原因:b进制下的数字可能大于10,不能用字符串存储,否则测试点2、4无法通过。

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,b;
        string s;
        scanf("%d %d",&n,&b);
        if(n==0) {
            cout<<"Yes"<<endl;
            cout<<0<<endl;return 0;
        }
        while(n){
            s.push_back(n%b+'0');
            n/=b;
        }
        string t=s;
        reverse(s.begin(),s.end());
        if(s==t) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
        for(int i=0;i<s.size();i++){
            cout<<s[i];
            if(i!=s.size()-1) cout<<" ";
        }
        return 0;
    }
    

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,b,flag=1;
        vector<int> s;
        scanf("%d %d",&n,&b);
        if(n==0) {
            cout<<"Yes"<<endl;
            cout<<0<<endl;return 0;
        }
        while(n){
            s.push_back(n%b);
            n/=b;
        }
        for(int i=0;i<s.size()/2;i++){
            if(s[i]!=s[s.size()-i-1]){
                cout<<"No"<<endl;
                flag=0;
    			//注意这里的break,输出No后记得跳出循环QAQ
                break;
            }
        }
        if(flag) cout<<"Yes"<<endl;
        for(int i=s.size()-1;i>=0;i--){
            cout<<s[i];
            if(i!=0) cout<<" ";
        }
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15521941.html

  • 相关阅读:
    centos出现“FirewallD is not running”怎么办
    Centos7开放及查看端口
    phpRedis函数使用总结
    如何在Windows的PHPstudy中使用redis
    Redis命令操作详解
    不可不知 DDoS的攻击原理与防御方法
    DDoS 攻击与防御:从原理到实践
    ORM Integrity constraint violation: 1052 Column 'id' in where clause is ambiguous
    PHP常用函数大全500+
    Linux彻底卸载Nginx
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15521941.html
Copyright © 2011-2022 走看看