zoukankan      html  css  js  c++  java
  • 1035 Password (20 分)(字符串处理)

    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line “There are N accounts and no account is modified” where N is the total number of accounts. However, if N is one, you must print “There is 1 account and no account is modified” instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
    

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
    

    Sample Input 2:

    1
    team110 abcdefg332
    

    Sample Output 2:

    There is 1 account and no account is modified
    

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
    

    Sample Output 3:

    There are 2 accounts and no account is modified
    

    题目大意:

    给定n个用户的姓名和密码,把密码中的1改为@,0改为%,l改为L,O改为o
    如果不存在需要修改的密码,则输出There are n accounts and no account is modified。注意单复数,如果只有一个账户,就输出There is 1 account and no account is modified

    分析:

    把需要改变的字符串改变后存储在字符串数组vector里面,根据数组里面元素的个数是否为0输出相应的结果

    原文链接:https://blog.csdn.net/liuchuo/article/details/52121759

    题解

    坑的点在于单复数要注意Orz

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,cnt=0;
        string name,s;
        vector<string> s1,s2;
        cin>>n;
        for(int i=0; i<n; i++)
        {
            bool flag=false;
            cin>>name>>s;
            for(int j=0; j<s.length(); j++)
            {
                if(s[j]=='l'){
                    s[j]='L';flag=true;
                }
                else if(s[j]=='0'-0){
                    s[j]='%';flag=true;
                }
                else if(s[j]=='1'-0){
                    s[j]='@';flag=true;
                }
                else if(s[j]=='O'){
                    s[j]='o';flag=true;
                }
            }
            if(flag) {
                cnt++;
                s1.push_back(name);s2.push_back(s);
            }
        }
        if(cnt==0) {
            if(n==1)
                cout<<"There is "<<n<<" account and no account is modified";
            else
                cout<<"There are "<<n<<" accounts and no account is modified";
        }
        else{
            cout<<cnt<<endl;
            for(int i=0;i<cnt;i++){
                cout<<s1[i]<<" "<<s2[i]<<endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    flutter 3des
    flutter踩坑记
    【OS_Windows】彻底关闭windows10自动更新
    使用 httpclient 上传下载文件
    git操作
    jmeter在Windows下请求https的接口
    python xlsxwriter简单使用
    asp.net core webapi 文件下载实现
    使用微信小程序连接到 MQTT 云服务
    MQTT.js 入门教程
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15563736.html
Copyright © 2011-2022 走看看