zoukankan      html  css  js  c++  java
  • 1042 Shuffling Machine (20 分)(模拟)

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2
    

    where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
    

    生词

    英文 解释
    procedure 手续,步骤
    randomize 随机化
    a deck of 一副
    collaborate with 合作
    gambler 赌徒
    inadequate 不足的
    casino 赌场
    Spade 黑桃
    Club 梅花
    Diamond 方块

    分析:

    简单模拟。使用start和end数组保存每一次变换的开始顺序和结束顺序(以1~54的编号存储),最后根据编号与扑克牌字母数字的对应关系输出end数组

    原文链接:https://blog.csdn.net/liuchuo/article/details/52108161

    题解

    注意用void函数直接对全局变量v进行shuffle是不可以的,因为这样每次操作都会将v的值改变,而应该用一个新的数组进行操作~

    //错误示范
    void shuffle(){
        for(int i=1;i<=54;i++){
            v[number[i]]=v[i];
        }
    }
    
    #include <bits/stdc++.h>
    
    using namespace std;
    
    vector<int> number(55);
    vector<string> shuffle(vector<string> v){
        vector<string> new_v(55);
        for(int i=1;i<=54;i++){
            new_v[number[i]]=v[i];
        }
        return new_v;
    }
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n,num;
        vector<string> v(55);
        cin>>n;
        for(int i=1; i<=54; i++)
        {
            cin>>num;
            number[i]=num;
        }
        for(int i=1; i<=13; i++) v[i]="S"+to_string(i);
        for(int i=14; i<=26; i++) v[i]="H"+to_string(i-13);
        for(int i=27; i<=39; i++) v[i]="C"+to_string(i-26);
        for(int i=40; i<=52; i++) v[i]="D"+to_string(i-39);
        for(int i=53; i<=54; i++) v[i]="J"+to_string(i-52);
        for(int i=0; i<n; i++)
        {
            v=shuffle(v);
        }
        cout<<v[1];
        for(int i=2;i<=54;i++)
            cout<<" "<<v[i];
        return 0;
    }
    

    柳神题解

    柳神的想法永远是那么精辟~

    #include <cstdio>
    using namespace std;
    int main() {
        int cnt;
        scanf("%d", &cnt);
        int start[55], end[55], scan[55];
        for(int i = 1; i < 55; i++) {
            scanf("%d", &scan[i]);
            end[i] = i;
        }
        for(int i = 0; i < cnt; i++) {
            for(int j = 1; j < 55; j++)
                start[j] = end[j];
            for(int k = 1; k < 55; k++)
                end[scan[k]] = start[k];
        }
        char c[6] = {"SHCDJ"};
        for(int i = 1; i < 55; i++) {
            end[i] = end[i] - 1;
            printf("%c%d", c[end[i]/13], end[i]%13+1);
            if(i != 54) printf(" ");
        }
        return 0;
    }
    
  • 相关阅读:
    E437: terminal capability "cm" required 错误出现的原因和解决方法
    IDEA 配置svn及使用
    IDEA 2018.3.3注册方法-2100年
    三大UML建模工具Visio、Rational Rose、PowerDesign的区别
    地图展示聚合效果Leaflet.markercluster
    Idea设置Maven报错:Unable to import maven project: See logs for details
    Netflix大部分的推荐机制都是采用机器学习的算法
    Netflix推荐系统:从评分预测到消费者法则
    Netflix推荐系统的最新解读:算法、商业价值与创新
    推荐系统算法总结
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15571066.html
Copyright © 2011-2022 走看看