zoukankan      html  css  js  c++  java
  • 1063 Set Similarity (25 分)(set)

    Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

    Input Specification:

    Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

    Output Specification:

    For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

    Sample Input:

    3
    3 99 87 101
    4 87 101 5 87
    7 99 101 18 5 135 18 99
    2
    1 2
    1 3

    Sample Output:

    50.0%
    33.3%

    题目大意:

    给定两个整数集合,它们的相似度定义为:Nc/Nt*100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度
    nc是两个集合的公共元素个数,nt是两个集合的所有包含的元素个数(其中元素个数表示各个元素之间互不相同)

    分析:

    因为给出的集合里面含有重复的元素,而计算nc和nt不需要考虑两个集合里面是否分别有重复的元素,所以可以直接使用set存储每一个集合,然后把set放进一个数组里面存储。当需要计算集合a和集合b的相似度nc和nt的时候,遍历集合a中的每一个元素,寻找集合b中是否有该元素,如果有,说明是两个人公共的集合元素,则nc++,否则nt++(nt的初值为b集合里面本有的元素)

    原文链接:https://blog.csdn.net/liuchuo/article/details/52138993

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n;
        cin>>n;
        set<int> a[n+1];
        for(int i=1;i<=n;i++){
            int k,tmp;
            cin>>k;
            for(int j=0;j<k;j++){
                cin>>tmp;
                a[i].insert(tmp);
            }
        }
        int t,x,y;
        cin>>t;
        for(int i=0;i<t;i++){
            cin>>x>>y;
            int nc=0,nt=a[y].size();
            for(auto it=a[x].begin();it!=a[x].end();it++){
                if(a[y].find(*it)==a[y].end()) nt++;
                else nc++;
            }
            printf("%.1f%%\n",(double)nc/nt*100);
        }
        return 0;
    }
    

    本文来自博客园,作者:勇往直前的力量,转载请注明原文链接:https://www.cnblogs.com/moonlight1999/p/15607210.html

  • 相关阅读:
    Android数据加密之异或加密算法
    Android数据加密之SHA安全散列算法
    Android数据加密之Base64编码算法
    Android数据加密之MD5加密
    Android业务组件化之子模块SubModule的拆分以及它们之间的路由Router实现
    Android业务组件化之现状分析与探讨
    Android业务组件化之URL Scheme使用
    Android消息传递之基于RxJava实现一个EventBus
    mysql存储中文乱码
    MongoDB中创建root的角色失败:Error couldn’t add user No role named root@test
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15607210.html
Copyright © 2011-2022 走看看