zoukankan      html  css  js  c++  java
  • 1069 The Black Hole of Numbers (20 分)(数学问题)

    For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

    For example, start from 6767, we'll get:

    7766 - 6677 = 1089
    9810 - 0189 = 9621
    9621 - 1269 = 8352
    8532 - 2358 = 6174
    7641 - 1467 = 6174
    ... ...
    

    Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

    Input Specification:

    Each input file contains one test case which gives a positive integer N in the range (0, 10000).

    Output Specification:

    If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

    Sample Input 1:

    6767

    Sample Output 1:

    7766 - 6677 = 1089
    9810 - 0189 = 9621
    9621 - 1269 = 8352
    8532 - 2358 = 6174

    Sample Input 2:

    2222

    Sample Output 2:

    2222 - 2222 = 0000

    分析:

    有一个测试用例注意点,如果当输入N值为6174的时候,依旧要进行下面的步骤,直到差值为6174才可以~所以用do while语句,无论是什么值总是要执行一遍while语句,直到遇到差值是0000或6174~

    s.insert(0, 4 – s.length(), ‘0’);用来给不足4位的时候前面补0~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52497341

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        int n;
        cin>>n;
        string s=to_string(n);
        if(s[0]==s[1]&&s[1]==s[2]&&s[2]==s[3]){
            printf("%04d - %04d = 0000\n",n,n);
            return 0;
        }
        do
        {
            int a=0,b=0,i=0;
            vector<int> v(4);
            while(n)
            {
                v[i++]=n%10;
                n/=10;
            }
            sort(v.begin(),v.end());
            int sum=1;
            for(int i=0; i<v.size(); i++)
            {
                a+=v[i]*sum;
                sum*=10;
            }
            sum=1;
            for(int i=v.size()-1; i>=0; i--)
            {
                b+=v[i]*sum;
                sum*=10;
            }
            printf("%04d - %04d = %04d\n",a,b,a-b);
            n=a-b;
        }while(n!=6174);
        return 0;
    }
    

    柳神短小精悍的代码

    膜QAQ

    #include <iostream>
    #include <algorithm>
    using namespace std;
    bool cmp(char a, char b) {return a > b;}
    int main() {
        string s;
        cin >> s;
        s.insert(0, 4 - s.length(), '0');
        do {
            string a = s, b = s;
            sort(a.begin(), a.end(), cmp);
            sort(b.begin(), b.end());
            int result = stoi(a) - stoi(b);
            s = to_string(result);
            s.insert(0, 4 - s.length(), '0');
            cout << a << " - " << b << " = " << s << endl;
        } while (s != "6174" && s != "0000");
        return 0;
    }
    
  • 相关阅读:
    hdu3746 KMP的next数组应用,求项链首尾项链循环
    hdu4067 费用流(混合欧拉的宽展和延伸)
    hdu4067 费用流(混合欧拉的宽展和延伸)
    hdu1501 记忆化搜索
    hdu1501 记忆化搜索
    hdu1316 大数
    hdu1316 大数
    hdu4411 经典费用里建图
    hdu4411 经典费用里建图
    hdu4768 非常规的二分
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15652239.html
Copyright © 2011-2022 走看看