zoukankan      html  css  js  c++  java
  • 1071 Speech Patterns (25 分)(map)

    People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

    Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

    Input Specification:

    Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

    Output Specification:

    For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

    Note that words are case insensitive.

    Sample Input:

    Can1: "Can a can can a can? It can!"

    Sample Output:

    can 5

    生词

    英文 解释
    synonym 同义词
    validate 验证
    avatar 虚拟化身
    alphanumerical 字母数字的
    lexicographically 字典序
    case insensitive 不区分大小写

    题目大意:

    统计单词个数~大小写字母+数字的组合才是合法的单词,给出一个字符串,求出现的合法的单词的个数最多的那个单词,以及它出现的次数。如果有并列的,那么输出字典序里面的第一个~~

    分析:

    用map很简单的~不过呢~有几个注意点~

    1. 大小写不区分,所以统计之前要先s[i] = tolower(s[i]);
    2. [0-9 A-Z a-z]可以简写为cctype头文件里面的一个函数isalnum~~
    3. 必须用getline读入一长串的带空格的字符串~~
    4. 一定要当t不为空的时候m[t]++,因为t为空也会被统计的!!!~~
    5. 最重要的是~如果i已经到了最后一位,不管当前位是不是字母数字,都得将当前这个t放到map里面(只要t长度不为0)~

    原文链接:https://blog.csdn.net/liuchuo/article/details/52225584

    题解

    注意if(!isalnum(s[i])||i == s.length() - 1)
    因为代码逻辑是当最后一个字符也是字母数字的时候,也要把t收纳的字母数字的字符串加入到map中~

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        map<string,int> m;
        string s,t;
        getline(cin,s);
        for(int i=0;i<s.length();i++){
            if(isalnum(s[i])){
                t.push_back(tolower(s[i]));
            }
            if(!isalnum(s[i])||i == s.length() - 1){
                if(t.size()>0) m[t]++;
                t.clear();
            }
        }
        int mmax=0;
        for(auto it=m.begin();it!=m.end();it++){
            if(it->second>mmax){
                t=it->first;
                mmax=it->second;
            }
        }
        cout<<t<<" "<<mmax;
        return 0;
    }
    
  • 相关阅读:
    开发新技术展望系列课程(视频课程讲师:徐晓卓)
    VSTS风暴系列课程(视频课程讲师:王京京/王兴明/王然)
    Mysql索引的数据结构及索引优化
    CAP原则,分布式场景下为何只能取其二
    为什么使用Redission解决高并发场景分布式锁问题
    Java面试题(6)Redis
    外企英语面试常见问题及核心话术
    Nacos&Eureka&Zookeeper
    j2ee中DAO设计模式
    第一个随笔
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15658888.html
Copyright © 2011-2022 走看看