zoukankan      html  css  js  c++  java
  • 1092 To Buy or Not to Buy (20 分)(hash散列)

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is “Yes”, please tell her the number of extra beads she has to buy; or if the answer is “No”, please tell her the number of beads missing from the string.

    For the sake of simplicity, let us use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is “Yes”, then also output the number of extra beads Eva has to buy; or if the answer is “No”, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:

    ppRYYGrrYBR2258
    YrR8RrY

    Sample Output 1:

    Yes 8

    Sample Input 2:

    ppRYYGrrYB225
    YrR8RrY

    Sample Output 1:

    No 2

    生词

    英文 解释
    beads 珠子

    题目大意:小红想买些珠子做一串自己喜欢的珠串。卖珠子的摊主有很多串五颜六色的珠串,但是不肯把任何一串拆散了卖。于是小红要你帮忙判断一下,某串珠子里是否包含了全部自己想要的珠子?如果是,那么告诉她有多少多余的珠子;如果不是,那么告诉她缺了多少珠子~

    分析:字符串a和b分别存储摊主的珠串和小红想做的珠串,遍历字符串a,将每一个字符出现的次数保存在book数组中,表示摊主的每个珠子的个数,遍历字符串b,如果book[b[i]]>0,表示小红要的珠子摊主有,则book[b[i]]-1,将这个珠子给小红~否则说明小红要的珠子摊主没有,则将统计缺了多少珠子的result++,如果result不等于0,说明缺珠子,则不可以买,输出No以及缺了的珠子个数result,否则说明不缺珠子,可以买,输出Yes以及摊主珠子多余的个数a.length() - b.length()~

    原文链接:https://blog.csdn.net/liuchuo/article/details/51985895

    题解

    #include <bits/stdc++.h>
    
    using namespace std;
    int book[256];
    int main()
    {
    #ifdef ONLINE_JUDGE
    #else
        freopen("1.txt", "r", stdin);
    #endif
        string a,b;
        cin>>a>>b;
        int cnt=0;
        for(int i=0;i<a.size();i++){
            book[a[i]]++;
        }
        for(int i=0;i<b.size();i++){
    
            if(book[b[i]]>0) book[b[i]]--;
            else cnt++;
        }
        if(cnt)  cout<<"No "<<cnt;
        else cout<<"Yes "<<a.size()-b.size();
        return 0;
    }
    
  • 相关阅读:
    java 键盘监听事件
    DOM扩展
    DOM
    CSS hack
    客户端检测
    BOM
    函数表达式
    面向对象的程序设计
    引用类型(下)
    引用类型(上)
  • 原文地址:https://www.cnblogs.com/moonlight1999/p/15759190.html
Copyright © 2011-2022 走看看