zoukankan      html  css  js  c++  java
  • 1029 Median (25 分)

    1029 Median (25 分)
     

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (2×105​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output Specification:

    For each test case you should output the median of the two given sequences in a line.

    Sample Input:

    4 11 12 13 14
    5 9 10 15 16 17
    

    Sample Output:

    13

    注意点:1.要考虑到m个数字已经输入完但是k还没到count的情况
        2.必须用cin.tie(0),否则超时。



    #include<bits/stdc++.h>
    using namespace std;
    
    const int maxn = 200010;
    
    int a[maxn];
    
    int n,m;
    
    int main(){
        
        ios::sync_with_stdio(false);
        cin.tie(0); 
        
        
        cin>>n;
        
        int i,j;
        
        for(i=0;i<n;i++)
            cin>>a[i];
            
        cin>>m;
        
        int count=0;
        
        bool flag=false;
        
        count=(m+n+1)/2;
        
        
        int k=0;
        
        
        int b;
        
        int ans;
        
        i=0;
        
        for(j=0;j<m&&k<count;j++){
            cin>>b;
            
            if(a[i]<=b){
                while(i<n&&a[i]<b){
                k++;
                if(k==count)
                {
                    ans=a[i];
                    break;
                }
                
                i++;
                }
                
                
            
            
        }
                
            k++;
        if(k==count)
        {
            ans=b;
            break;
        }
            
        
                
            
        }
        
        
        while(k<count&&i<n){
            ans=a[i];
            i++;
            k++;
        }
        
         
    //    cout<<count<<endl;
        cout<<ans<<endl; 
        
        
            
                
    }
     
  • 相关阅读:
    GIT和SVN之间的五个基本区别
    IOS多线程(NSThread,NSOperation,Grand Central Dispatch)
    MV*模型及部分vue
    你未必知道的49个CSS知识点--(转发地址)
    VUE增删改查
    动态树形菜单的几种递归写法小结
    vue-cli
    git的使用
    自动化构建工具----gulp
    前端包管理工具—bower
  • 原文地址:https://www.cnblogs.com/moranzju/p/11158529.html
Copyright © 2011-2022 走看看