zoukankan      html  css  js  c++  java
  • poj 1222 EXTENDED LIGHTS OUT(高斯消元)

    EXTENDED LIGHTS OUT
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 6852   Accepted: 4521

    Description

    In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

    The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

    Note: 
    1. It does not matter what order the buttons are pressed. 
    2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
    3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
    four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
    Write a program to solve the puzzle.

    Input

    The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

    Output

    For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

    Sample Input

    2
    0 1 1 0 1 0
    1 0 0 1 1 1
    0 0 1 0 0 1
    1 0 0 1 0 1
    0 1 1 1 0 0
    0 0 1 0 1 0
    1 0 1 0 1 1
    0 0 1 0 1 1
    1 0 1 1 0 0
    0 1 0 1 0 0

    Sample Output

    PUZZLE #1
    1 0 1 0 0 1
    1 1 0 1 0 1
    0 0 1 0 1 1
    1 0 0 1 0 0
    0 1 0 0 0 0
    PUZZLE #2
    1 0 0 1 1 1
    1 1 0 0 0 0
    0 0 0 1 0 0
    1 1 0 1 0 1
    1 0 1 1 0 1

    Source



    题意:
    给你一个5*6的矩阵,0代表灯熄。1代表灯亮。求一个解决方式。使全部灯都灭。

    题解;
    看了非常久的题解才搞懂的高斯消元解法。关键是怎样构建方程。

    下面是我摘抄的较具体的解释了:

    转载分析:这个游戏的名字叫做Lights Out。一个板子上面有MxN个button,button也是灯。每次按下一个button,这个button和它的上下左右相邻button将同一时候切换各自的亮灭状态。给你一个初始状态。请给出一种方法。按某些button。使得全部的灯都灭。

    这个游戏有一些技巧: 
    1、按button的顺序能够随便。 
    2、不论什么一个button都最多须要按下1次。由于按下第二次刚好抵消第一次,等于没有按。

     

    这个问题能够转化成数学问题。

     
    一个灯的布局能够看成一个0、1矩阵。以3x3为例: 
    0 1 0 
    1 1 0 
    0 1 1 
    表示一个布局。

    当中0表示灯灭,1表示灯亮。

     
    每次按下button(POJ1222)或者叫一个宿舍关灯(0998)。能够看成在原矩阵上加(模2加,就是按位异或)上一个例如以下的矩阵: 
    0 1 0 
    1 1 1 
    0 1 0 
    上述矩阵中的1表示按下第2行第2列的button时。作用的范围。假设按左上角的button,就是: 
    1 1 0 
    1 0 0 
    0 0 0 

    我们记L为待求解的原始布局矩阵。A(i,j)表示按下第i行第j列的button时的作用范围矩阵。在上述样例中, 
    L= 
    0 1 0 
    1 1 0 
    0 1 1 

    A(1,1)= 
    1 1 0 
    1 0 0 
    0 0 0 

    A(2,2)= 
    0 1 0 
    1 1 1 
    0 1 0 

    如果x(i,j)表示:想要使得L回到全灭状态,第i行第j列的button是否须要按下。

    0表示不按,1表示按下。那么,这个游戏就转化为例如以下方程的求解: 
    L + x(1,1)*A(1,1) + x(1,2)*A(1,2) + x(1,3)*A(1,3) + x(2,1)*A(2,1) + ... + x(3,3)*A(3,3) = 0 

    当中x(i,j)是未知数。方程右边的0表示零矩阵,表示全灭的状态。直观的理解就是:原来的L状态,经过了若干个A(i,j)的变换,终于变成0:全灭状态。

     
    因为是0、1矩阵。上述方程也能够写成: 
    x(1,1)*A(1,1) + x(1,2)*A(1,2) + x(1,3)*A(1,3) + x(2,1)*A(2,1) + ... + x(3,3)*A(3,3) = L 

    这是一个矩阵方程。

    两个矩阵相等,充要条件是矩阵中每一个元素都相等。将上述方程展开。便转化成了一个9元1次方程组: 

    简单地记做:AA * XX = LL 

    这个方程有唯一解: 
    x(1,1) x(1,2) x(1,3) 
    x(2,1) x(2,2) x(2,3) 
    x(3,1) x(3,2) x(3,3) 

    1 1 1 
    0 0 0 
    0 0 1 

    也就是说。按下第一行的3个button,和右下角的button,就

    能使L状态变成全灭状态。 
    对于固定行列的阵列来说。AA矩阵也是确定的。是否存在解。解是否唯一,仅仅与AA矩阵有关。

    对于唯一解的情形,仅仅要将LL乘以AA的逆矩阵就可以。详细求AA的逆矩阵的方法,能够用高斯消元法。

     

    因为是0、1矩阵,上述方程也能够写成:

    将1式两边同一时候加上一个L矩阵就能够变成
    x(1,1)*A(1,1) + x(1,2)*A(1,2) + x(1,3)*A(1,3) + x(2,1)*A(2,1) + ... + x(3,3)*A(3,3) = L

    A(1。1)把矩阵 转化为一个列向量,L也转化为一个列向量。

    将sigma xi*Ai=Li 相应位置的值相等就能够建立方程组了

    X1*A(1,1)1+X2*A(1,2)1+X3*A(1,3)1+…………X30*A(30,30)1=L1;    mod 2

    X1*A(1,1)2+X2*A(1,2)2+X3*A(1,3)2+…………X30*A(30,30)2=L2;    mod 2

    X1*A(1,1)3+X2*A(1,2)3+X3*A(1,3)3+…………X30*A(30,30)3=L3    mod 2

    …….

    …….

    …….

    X1*A(1,1)30+X2*A(1,2)30+X3*A(1,3)30+…………X30*A(30,30)30=L30; mod 2

    当中A(i,j)k 表示列向量A中第K个元素

    这里的*表示点乘,Xi取(1,0) +表示模2加法,所以在高斯消元的时候能够用^异或运算


    CODE:

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    #include<cmath>
    
    using namespace std;
    
    int map[33][33];
    
    void init()
    {
        for ( int i = 1; i <= 30; i++ )
        {
            map[i][i] ^= 1;
            if ( ( i % 6 ) != 1 )///注意边界
                map[i ][i - 1] ^= 1;///左
            if ( i % 6 )
                map[i][i + 1] ^= 1;///右
            if ( i - 6 > 0 )
            {
                map[i][i - 6] ^= 1;///上
            }
            if ( i + 6 <= 30 )
                map[i][i + 6] ^= 1;///下
        }
    }
    
    void gauss()
    {
        for ( int i = 1; i <= 30; i++ )
        {
            if ( map[i][i] == 0 )
            {
                int ii = i + 1;
                while ( ii <= 30 && map[ii][i] == 0 )  ii++;
                for ( int r = 1; r <= 31; r++ )
                    swap ( map[ii][r], map[i][r] );
            }
            for ( int j = 1; j <= 30; j++ )
            {
                if ( i == j )
                    continue;
                if ( map[j][i] == 0 )
                    continue;
                for ( int k = i; k <= 31; k++ )
                {
                    map[j][k] ^= map[i][k];
                }
            }
        }
    }
    
    int main()
    {
        int t;
        while ( ~scanf ( "%d", &t ) )
        {
            int ca = 1;
            while ( t-- )
            {
                memset ( map, 0, sizeof ( map ) );
                int a[33];
                for ( int i = 1; i <= 30; i++ )
                    scanf ( "%d", &a[i] );
                init();
                cout << "PUZZLE #" << ca++ << endl;
                for ( int i = 1; i <= 30; i++ )
                    map[i][31] = a[i];
                gauss();
                for ( int i = 1; i <= 30; i++ )
                {
                    if ( i % 6 == 0 )
                        cout << map[i][31] << endl;
                    else
                        cout << map[i][31] << ' ';
                }
            }
        }
        return 0;
    }
    



  • 相关阅读:
    Anaconda+Tensorflow环境安装与配置(转载)
    Win10 Anaconda下TensorFlow-GPU环境搭建详细教程(包含CUDA+cuDNN安装过程)(转载)
    设计模式之工厂方法模式VS简单工厂方法模式
    WPF之外观模式
    WPF之小动画三
    WPF之小动画二
    WPF之小动画一
    WPF之Behavior
    WPF之拖动项滚动条自滚动(当拖动项到达高度的边界时候滚动条自己可以上下滚动)
    WPF之给使用了模板的MenuItem添加快捷操作
  • 原文地址:https://www.cnblogs.com/mthoutai/p/6934516.html
Copyright © 2011-2022 走看看