zoukankan      html  css  js  c++  java
  • POJ 1281 MANAGER

    MANAGER
    Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

    Description

    One of the programming paradigm in parallel processing is the producer/consumer paradigm that can be implemented using a system with a "manager" process and several "client" processes. The clients can be producers, consumers, etc. The manager keeps a trace of client processes. Each process is identified by its cost that is a strictly positive integer in the range 1 .. 10000. The number of processes with the same cost cannot exceed 10000. The queue is managed according to three types of requests, as follows:
    • a x - add to the queue the process with the cost x;
    • r - remove a process, if possible, from the queue according to the current manager policy;
    • p i - enforce the policy i of the manager, where i is 1 or 2. The default manager policy is 1
    • e - ends the list of requests.

    There are two manager policies:
    • 1 - remove the minimum cost process
    • 2 - remove the maximum cost process

    The manager will print the cost of a removed process only if the ordinal number of the removed process is in the removal list.

    Your job is to write a program that simulates the manager process.

    Input

    The input is from the standard input. Each data set in the input has the following format:
    • the maximum cost of the processes
    • the length of the removal list
    • the removal list - the list of ordinal numbers of the removed processes that will be displayed; for example 1 4 means that the cost of the first and fourth removed processes will be displayed
    • the list of requests each on a separate line.

    Each data set ends with an e request. The data sets are separated by empty lines.

    Output

    The program prints on standard output the cost of each process that is removed, provided that the ordinal number of the remove request is in the list and the queue is not empty at that moment. If the queue is empty the program prints -1. The results are printed on separate lines. An empty line separates the results of different data sets.

    An example is given in the following:

    Sample Input

    5
    2
    1 3
    a 2
    a 3
    r
    a 4
    p 2
    r
    a 5
    r
    e

    Sample Output

    2
    5


    题目大意:

    线程模拟。

    ax——将一个花费为x的进程加到队列中

    r——假设可能。依照当前管理者的策略,删除一个进程

    p i ——运行管理者的策略i。当中i是1或者2。缺省值为1

    e——请求列表终止

    两个管理者的策略为:

    1——删除最小耗费进程

    2——删除最大耗费进程

    输出指定的删除序列

    #include <iostream>
    #include<algorithm> 
    using namespace std;
    int cmp1(int a,int b)
    {
    	return a>b;
    }
    int cmp2(int a,int b)
    {
    	return a<b;
    }
    int main()
    {
    	
        int num;
        while(cin>>num&&num)
    	{
    		int p=1;
    		int n;
    		cin>>n;
    		int a[1010]={0},b[1010]={0},c[2010]={0};
    		int i;
    		for(i=1;i<=n;i++)
    			cin>>b[i];
    		int a1=1,b1=1,c1=1;
    		char ch;
    		i=0;    
    		while(cin>>ch&&ch!='e')
    		{
    			if(ch=='a')
    			{
    				cin>>a[a1];
    				a1++;
    			}
    			if(ch=='p')
    				cin>>p;
    			if(ch=='r')
    			{
    				if(p==1)//删除最小进程
    				{
    					sort(a+1,a+a1,cmp1);
    					c[c1]=a[a1-1];
    					c1++;
    					a1=a1-1;
    				}
    				if(p==2)//删除最大进程
    				{
    					sort(a+1,a+a1,cmp2);
    					c[c1]=a[a1-1];
    					c1++;
    					a1=a1-1;
    				}
    			}
    		}
    		for(i=1;i<=n;i++)
    			cout<<c[b[i]]<<endl;
    		cout<<endl;
    	}
    	return 0;
    }
    
    /*
    5
    2
    1 3
    a 2
    a 3
    r
    a 4
    p 2
    r
    a 5
    r
    e
    */
    
    

    刚開始提交WrongAnswer 后来注意到时sort函数的使用,数组開始下标从0開始还是从1開始sort括号中的的列表不同,

    sort(a+1,a+a1,cmp1);
    我的下标从1開始。

    sort函数详情见http://blog.csdn.net/sunshumin/article/details/37756027

    再提交时是PE错误,改成一次while循环加一个空行。ac。

  • 相关阅读:
    AOP AspectJ 字节码 语法 MD
    判断小米华为等系统 MD
    vuejs2.0实现分页组件,使用$emit进行事件监听数据传递
    vuejs2.0实现一个简单的分页
    vuejs2.0使用Sortable.js实现的拖拽功能
    JavaScript之Number、String、Array常用属性与方法手册
    CSS3效果:5种预载动画效果
    vuejs 1.x
    window.requestAnimationFrame与Tween.js配合使用实现动画缓动效果
    如何用JavaScript判断dom是否有存在某class的值?
  • 原文地址:https://www.cnblogs.com/mthoutai/p/6946752.html
Copyright © 2011-2022 走看看