zoukankan      html  css  js  c++  java
  • 【PAT甲级】1004 Counting Leaves (30分):DFS/BFS树的遍历

    1004 Counting Leaves (30分)

    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    
          
        
    

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    The input ends with N being 0. That case must NOT be processed.

    Output Specification:

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

    Sample Input:

    2 1
    01 1 02
    
          
        
    

    Sample Output:

    0 1
    

    分析:BFS/DFS遍历树

    输出每一层叶子节点的个数。

    • BFS:

      设置layer[]记录每层叶子节点的个数。

      节点结构体中设置lay,记录节点所在层数。每次队列push孩子节点时,更新孩子节点所在层数:Node[top].lay+1。若一个结点没有孩子节点,则是叶子,layer[该节点]++。遍历过程中,记录最深节点所在层数。

      最后输出层数个数字。


    代码

    • BFS
    /*BFS遍历树,数每层叶子节点的个数*/
    #include<iostream>
    #include<vector>
    #include<queue>
    
    using namespace std;
    
    const int maxN=110;
    const int maxM=110;
    struct node {
    	int lay;//所在层数(0开始)
    	vector<int> child;//孩子节点
    } Node[maxM];
    int layer[maxM]; //每层叶子节点的个数
    int N,M;
    int maxLayer=0;//最深节点的层数(0开始 )
    
    void BFS() {
    	queue<int> que;
    	que.push(1);//根节点
    
    	while(!que.empty()) {
    		int top=que.front();
    		que.pop();
    		if(Node[top].lay>maxLayer)
    			maxLayer=Node[top].lay;
    
    		bool leafFlag=true;//是否是叶子节点
    		for(int i=0; i<Node[top].child.size(); i++) {
    			leafFlag=false;
    			int index=Node[top].child[i];
    			Node[index].lay=Node[top].lay+1;
    			que.push(index);
    		}
    		if(leafFlag)
    			layer[Node[top].lay]++;
    	}
    }
    
    int main() {
    	fill(layer,layer+maxM,0);
    	int id1,chNo,id2;
    	scanf("%d%d",&N,&M);
    	for(int i=0; i<M; i++) {
    		scanf("%d%d",&id1,&chNo);
    		for(int j=0; j<chNo; j++) {
    			scanf("%d",&id2);
    			Node[id1].child.push_back(id2);
    		}
    	}
    
    	BFS();
    
    	for(int i=0; i<=maxLayer; i++) {
    		if(i!=0) cout<<" ";
    		cout<<layer[i];
    	}
    
    
    	return 0;
    }
    

    • DFS:(柳神的)
    /*DFS遍历*/
    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    vector<int> v[100];
    int book[100], maxdepth = -1;
    void dfs(int index, int depth) {
        if(v[index].size() == 0) {
            book[depth]++;
            maxdepth = max(maxdepth, depth);
            return ;
        }
        for(int i = 0; i < v[index].size(); i++)
            dfs(v[index][i], depth + 1);
    }
    int main() {
        int n, m, k, node, c;
        scanf("%d %d", &n, &m);
        for(int i = 0; i < m; i++) {
            scanf("%d %d",&node, &k);
            for(int j = 0; j < k; j++) {
                scanf("%d", &c);
                v[node].push_back(c);
            }
        }
        dfs(1, 0);
        printf("%d", book[0]);
        for(int i = 1; i <= maxdepth; i++)
            printf(" %d", book[i]);
        return 0;
    }
    

    测试数据:


    6 3
    01 2 02 05
    02 2 03 04
    05 1 06
    
    
  • 相关阅读:
    Luogu 4841 城市规划
    Luogu 4721 【模板】分治 FFT
    Luogu 4091 [HEOI2016/TJOI2016]求和
    Luogu 3723 [AH2017/HNOI2017]礼物
    FFT笔记
    Luogu 4900 食堂
    Luogu 4155 [SCOI2015]国旗计划
    Luogu 4069 [SDOI2016]游戏
    Luogu 4254 [JSOI2008]Blue Mary开公司
    Luogu 4251 [SCOI2015]小凸玩矩阵
  • 原文地址:https://www.cnblogs.com/musecho/p/12317017.html
Copyright © 2011-2022 走看看