zoukankan      html  css  js  c++  java
  • 杭电 oj Rescue 1242

    Rescue

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 29830 Accepted Submission(s): 10504

    Problem Description
    Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

    Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

    You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

    Input
    First line contains two integers stand for N and M.

    Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

    Process to the end of the file.

    Output
    For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

    Sample Input
    7 8
    #.#####.
    #.a#..r.
    #..#x…
    ..#..#.#
    #…##..
    .#……
    ……..

    Sample Output
    13

    #include<iostream>
    #include<algorithm>
    #include<queue>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    struct node
    {
        int x,y,time;
        friend bool operator<(node a1,node a2)
        {
            return a1.time>a2.time;
        }
    }as,t,h,x1;
    int i,j,k,n,m;
    int dir[4][2]={{0,1},{0,-1},{-1,0},{1,0}};
    char a[202][202];
    int b[202][202];
    void dfs()
    {
        priority_queue<node>q;
        q.push(h);
        while(!q.empty())
        {
            t=q.top();
            q.pop();
            if(a[t.x][t.y]=='r')
            {
                cout<<t.time<<endl;
                    return ;
            }
            //cout<<t.time<<" "<<t.x<<" "<<t.y<<endl;
            for(int l=0;l<4;l++)
            {
                x1.x=t.x+dir[l][0];
                x1.y=t.y+dir[l][1];
                if(a[x1.x][x1.y]!='#'&&x1.x>=1&&x1.x<=n&&x1.y>=1&&x1.y<=m&&b[x1.x][x1.y]==0)
                {
                    if(a[x1.x][x1.y]=='x')
                        x1.time=t.time+2;
                    else
                        x1.time=t.time+1;;
                    b[x1.x][x1.y]=1;
                    q.push(x1);
                }
            }
        }
        cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
    }
    int main()
    {
        while(cin>>n>>m)
        {
            memset(b,0,sizeof(b));
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    cin>>a[i][j];
                    if(a[i][j]=='a')
                    {
                        h.x=i;
                        h.y=j;
                        h.time=0;
                    }
    `
                }
            }
            dfs();
        }
        return 0;
    }
    
  • 相关阅读:
    jquery扩展鼠标mousewheel事件
    addEventListener和attachEvent介绍, 原生js和jquery的兼容性写法
    HTML,CSS,font-family:中文字体的英文名称
    最好的Java和Android开发IDE---IntelliJ IDEA使用技巧
    《Thinking in Java》习题——吸血鬼数字
    Java学习之——JavaBeans
    Android 开源库——侧滑菜单栏(SlidingMenu)的导入和使用
    Android 布局学习之——Layout(布局)详解二(常见布局和布局参数)
    Android 布局学习之——Layout(布局)详解一
    Android 布局学习之——LinearLayout的layout_weight属性
  • 原文地址:https://www.cnblogs.com/nanfenggu/p/7900185.html
Copyright © 2011-2022 走看看