zoukankan      html  css  js  c++  java
  • map 杭电 1039

    Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate “pronounceable” passwords that are relatively secure but still easy to remember.

    FnordCom is developing such a password generator. You work in the quality control department, and it’s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

    It must contain at least one vowel.

    It cannot contain three consecutive vowels or three consecutive consonants.

    It cannot contain two consecutive occurrences of the same letter, except for ‘ee’ or ‘oo’.

    (For the purposes of this problem, the vowels are ‘a’, ‘e’, ‘i’, ‘o’, and ‘u’; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

    Input
    The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end’ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

    Output
    For each password, output whether or not it is acceptable, using the precise format shown in the example.

    Sample Input
    a
    tv
    ptoui
    bontres
    zoggax
    wiinq
    eep
    houctuh
    end

    Sample Output
    < a > is acceptable.
    < tv > is not acceptable.
    < ptoui > is not acceptable.
    < bontres > is not acceptable.
    < zoggax > is not acceptable.
    < wiinq > is not acceptable.
    < eep > is acceptable.
    < houctuh> is acceptable.

    #include<iostream>
    #include<algorithm>
    #include<map>
    #include<string>
    #include<cstring>
    using namespace std;
    int main()
    {
        map<char ,int >as;
        as['a']=1;
        as['e']=1;
        as['i']=1;
        as['o']=1;
        as['u']=1;
        string a;
        while(cin>>a)
        {
            if(a=="end")
                break;
            int i,j,e=0,f=0,k=0;
            int l=a.length();
            for(i=0;i<l;i++)
            {
                if(as[a[i]]==1)
                {
                    e=1;
                    break;
                }
            }
            for(i=0;i<l-2;i++)
            {
                if((as[a[i]]==1&&as[a[i+1]]==1&&as[a[i+2]]==1)||((as[a[i]]==0&&as[a[i+1]]==0&&as[a[i+2]]==0)))
                {
                    f=1;
                    break;
                }
            }
            for(i=0;i<l-1;i++)
                if(a[i]==a[i+1])
                {
                    if(a[i]=='e'||a[i]=='o')
                        continue;
                    k=1;
                    break;
                }
            if(e==1&&f==0&&k==0)
                cout<<"<"<<a<<">"<<" is acceptable."<<endl;
            else
                cout<<"<"<<a<<">"<<" is not acceptable."<<endl;
        }
    return 0;
    }
    
  • 相关阅读:
    选择人员参与游戏的小程序
    Android系统 手机需要用到的命令
    Portal 开发
    又见好书 net4.0面向对象编程漫谈
    IOS UITableView reloadData not respone!
    android开发的注意问题
    BW数据转换中出现的#非法字符错误
    GIT版本控制使用小结
    好书伴我行
    LogMonitorAgent小结
  • 原文地址:https://www.cnblogs.com/nanfenggu/p/7900190.html
Copyright © 2011-2022 走看看