zoukankan      html  css  js  c++  java
  • 杭电 字符串处理 map

    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(‘ ’), enter(‘ ’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

    Output
    In this problem, you have to output the translation of the history book.

    Sample Input
    START
    from fiwo
    hello difh
    mars riwosf
    earth fnnvk
    like fiiwj
    END
    START
    difh, i’m fiwo riwosf.
    i fiiwj fnnvk!
    END

    Sample Output
    hello, i’m from mars.
    i like earth!

    [hint]
    Huge input, scanf is recommended.
    [/hint]

    #include<iostream>
    #include<algorithm>
    #include<map>
    #include<cstdio>
    #include<string>
    #include<cstring>
    using namespace std;
    int main()
    {
        int i,j;
        string a,b,c;
        string m;
        char n[10000];
        cin>>a;
        map<string ,string >as;
        while(cin>>b,b!="END")
        {
            cin>>c;
            as[c]=b;
        }
        cin>>a;
        getchar();
        while(1)
        {
            gets(n);
            int l=strlen(n);
            if(strcmp(n,"END")==0)
                break;
            m="";
            for(i=0;i<l;i++)
            {
                if(n[i]<'a'||n[i]>'z')
                {
                    if(as[m]!="")
                        cout<<as[m];
                    else
                        cout<<m;
                    m="";
                    cout<<n[i];
                }
                else
                    m=m+n[i];
            }
            cout<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    第五章总结
    第二章总结
    第一章、基础知识总结
    实验 9 根据材料编程
    实验5
    汇编实验4
    实验 3 编程、编译、连接、跟踪
    实验 2 用机器指令和汇编指令编程
    汇编-实验一
    react面试笔录
  • 原文地址:https://www.cnblogs.com/nanfenggu/p/7900196.html
Copyright © 2011-2022 走看看