zoukankan      html  css  js  c++  java
  • hdu 1087 动态规划

    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 18857    Accepted Submission(s): 8094


    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     
    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the maximum according to rules, and one line one case.
     
    Sample Input
    3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
     
    Sample Output
    4 10 3
     
    /*
    最大递增子序列 
    
    设第i个数的值为a[i] start到第i个数的最大值为dp[i]
    
    dp[i]=max(dp[k])+a[i]    a[k]是满足a[k]<a[i]且k<i的最大值
    
    */
    #include<iostream>
    using namespace std;
    int main(){
        int n;
        while(cin>>n){
            if (n==0)
                break;
            int dp[1010]={0};//最大和
            int b[1010]={0};//当前数
    
            for(int i=0;i<n;i++)
            {
                int temp;
                int max=0;
                                                                             //cin>>temp;
                cin>>b[i];                                                   //b[i]=temp;
                for(int j=0;j<i;j++)
                {
                    if((b[j]<b[i])&&(dp[j]>max))
                        max=dp[j];
    
                }
                dp[i]=max+b[i];
            }
    
    
    
            int ans=-1;
            for(int i=0;i<n;i++)   //求出最大的dp[]
            {
                if(ans<dp[i])
                    ans=dp[i];
            }
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Linux 文件权限
    Linux 查看磁盘使用情况
    绑定到外部验证服务LDAP、配置 autofs
    创建逻辑卷
    查找一个字符串
    查找用户目录下的指定文件
    配置NTP时间服务器
    通过Roslyn构建自己的C#脚本(更新版)(转)
    Elon Musk
    可能改变世界的13个“终结”(上)
  • 原文地址:https://www.cnblogs.com/neverchanje/p/3492963.html
Copyright © 2011-2022 走看看