zoukankan      html  css  js  c++  java
  • 乘法与位数

    题目意思:

    给你一个数,然后转化成相应进制的数,算出阶乘以后,求阶乘的位数

    阶乘的位数我们这么来算:

    例如1000的阶乘log10(1) + log10(2) + ...+log10(1000) 取整后加1

    然后转化成进制的话就是: 除以log10(base) 后加1

    题目:

    Description

    Factorial of an integer is defined by the following function

    f(0) = 1

    f(n) = f(n - 1) * n, if(n > 0)

    So, factorial of 5 is 120. But in different bases, the factorial may be different. For example, factorial of 5 in base 8 is 170.

    In this problem, you have to find the number of digit(s) of the factorial of an integer in a certain base.

    Input

    Input starts with an integer T (≤ 50000), denoting the number of test cases.

    Each case begins with two integers n (0 ≤ n ≤ 106) and base (2 ≤ base ≤ 1000). Both of these integers will be given in decimal.

    Output

    For each case of input you have to print the case number and the digit(s) of factorial n in the given base.

    Sample Input

    5

    5 10

    8 10

    22 3

    1000000 2

    0 100

    Sample Output

    Case 1: 3

    Case 2: 5

    Case 3: 45

    Case 4: 18488885

    Case 5: 1

     N!在十进制下的位数就是  log10 ( N ! )  +1  ( 自己找个数验证 ) ,N!在K进制下的位数就是  logK( N ! )  +1  ( K 为底数 )
    而计算机不能直接以K为底求对数。所以运用换底公式, logK( N ! )  = log( N! ) / log ( K )   ,注意,等号右边的 log 都是

    默认以e为底。

     

    正式进入解题了,题目给出N,K,如果每一次输入N,K 都要计算 N!的话,那就有很大的开销,开销为O(N)。

    所以可以采取一种办法,先预处理,用double数组 sum[ 1000000 ] 把 log ( N ! )  存起来。数组 应该够的,需要说的是定义大

    数组尽量放到外面,这样比较妥当,要不运行时会出错。

    用sum [ i ] 表示  log(1 )+log(2)+。。。+log(i) , 这样时间开始时花费O(N),之后每次花费O(1),等输入的

    时候用换底公式处理一下就得到答案了。

    代码:

    #include <cstdio>
    #include <cstring>
    #include <cmath>

    double SumAdd[1000000 + 10];

    int main(){
    int cas = 0 , t , n , base , i ;
    scanf("%d",&t);
    for(i = 1 ; i < 1000010 ; i ++)
    SumAdd[i] = SumAdd[i-1] + log(i * 1.0);
    while(t--){
    scanf("%d%d",&n,&base);
    printf("Case %d: %d ",++cas,(int)(SumAdd[n] / log(base * 1.0))+1);
    }
    }

  • 相关阅读:
    LINQ to SQL活学活用(2):躲起来别让我看见
    UTF8的問題
    简单的appendChild示例
    LINQ to SQL活学活用(4):监视你的一举一动
    LinQ中的SortBy+sum+count的用法
    ajax的问题
    [综] Canny Edge Detection 代码
    [转] 图像处理中的拉普拉斯算子
    [ZZ] SCI 投稿全过程信件模板一览
    [转] MATLAB图像实用源代码
  • 原文地址:https://www.cnblogs.com/newadi/p/3927273.html
Copyright © 2011-2022 走看看