zoukankan      html  css  js  c++  java
  • HDU A + B Problem II

    A + B Problem II

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 307 Accepted Submission(s): 147
    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output

                For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2
    1 2
    112233445566778899 998877665544332211
     
    Sample Output
    Case 1:
    1 + 2 = 3
    
    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110
    字符串模拟大数加法
    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    using namespace
    std;
    char
    sum[1000];
    void
      add(string a,string b)
    {

         string c ;
        if
    (a.length()<b.length())
        {
    c = a ; a = b; b = c;}
        int
    l1 = a.length()-1;
        int
    l2 = b.length()-1;
        int
    k=0,i=0;
        memset(sum,0,sizeof(sum));
        char
    t;
            while
    (l2!=-1)
            {

               t = (a[l1]-'0')+(b[l2]-'0');
               sum[i]= (t+k)%10+'0';
               k = (t+k)/10;
               l1--;
               l2--;
               i++;
            }

             while
    (l1!=-1)
             {

                 t = (a[l1]-'0');
                 sum[i] = (k+t)%10+'0';
                 k = (t+k)/10;
                 l1--;
                 i++;
             }

             if
    (k!=0)sum[i]=k+'0';
    }

    int
    main()
    {

        string a,b;
        int
    T;
        cin>>T;
        for
    (int i = 1 ; i <= T ;i ++)
        {

            cin>>a>>b;
            add(a,b);
            cout<<"Case "<<i<<":"<<endl;
            cout<<a<<" + "<<b<<" = ";
            for
    (int j = strlen(sum)-1; j >=0;j--)
            {

                cout<<sum[j];
            }

            if
    (i<T)
            cout<<endl<<endl;
            else
    cout<<endl;
        }

        return
    0;
    }
  • 相关阅读:
    CentOS 安装Redis
    python中Url链接编码处理(urlencode,urldecode)
    Flask+mongodb 实现简易个人博客
    Flask中mongodb实现flask_login保持登录
    ubuntu环境变量添加变量
    终端执行python shell的方法
    简单的模拟登录Wap版新浪微博
    爬取淘宝模特信息并自动保存图片
    Python字符串的encode与decode
    python3 安装scrapy Exception: Traceback (most recent call last): File "/usr/lib/python3/dist-packages/pip/req/req_install.py", line 1006, in check_if_exists解决方法
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2122519.html
Copyright © 2011-2022 走看看