zoukankan      html  css  js  c++  java
  • hdu Count the Trees

    Count the Trees

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 135 Accepted Submission(s): 102
    Problem Description
    Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.
    Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

    For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.

    If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

     
    Input
    The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.
     
    Output
    For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.
     
    Sample Input
    1
    2
    10
    25
    0
     
    Sample Output
    1
    4
    60949324800
    75414671852339208296275849248768000000
     
     
    给定n个元素,求组成的树的不同的结构的个数。
          分析:元素的排列方式为n!种,树的结构不同形式为卡特兰数C(n),
          所以:总共的数的不同结构为n!*C(n);

    import java.util.*;

    import java.math.*;
    public class
    Main {

        public static
    void main(String[] args){
        Scanner
    cin = new Scanner(System.in);
        BigDecimal
    []a = new BigDecimal[101];
        BigDecimal
    []kt = new BigDecimal[101];
        BigDecimal
    b,n;
        int
    k;

        a[0] = BigDecimal.valueOf(1);
        for
    (int i = 1 ; i < 101;i++){

           b = a[i-1].multiply(BigDecimal.valueOf(i));
           a[i] = b;
        }

        kt[1] = BigDecimal.valueOf(1);
        for
    (int i = 2;i< 101;i++){

        n = BigDecimal.valueOf(i);
        b = BigDecimal.valueOf(4).multiply(n);
        b = b.subtract(BigDecimal.valueOf(2));
        n = n.add(BigDecimal.valueOf(1));
        b = b.multiply(kt[i-1]);
        kt[i] = b.divide(n);
        }

          while
    (cin.hasNext()){

          k = cin.nextInt();
          if
    (k==0)break;

          b = a[k].multiply(kt[k]);
          System
    .out.println(b);
          }
        }
    }

  • 相关阅读:
    前端时间格式化
    Navicat for Oracle
    在JSP中使用Session
    在JSP中使用MD5
    QTP的那些事用QTP测试Web上的Ajax
    VBS函数应用getobject的使用获得Automation对象
    QTP的那些事Excel导入QC没反应的解决方法
    QTP的那些事QC远程执行QTP经常出现QTP崩溃现象解决方案
    QTP的那些事自动化的个人体会感悟(转)
    QC在win7远程执行QTP脚本excel不能读取,及其其他win7问题解决方案(图解转)
  • 原文地址:https://www.cnblogs.com/newpanderking/p/2122522.html
Copyright © 2011-2022 走看看