zoukankan      html  css  js  c++  java
  • LACP 链路汇聚控制协议

    1.1         Load balance

    配置静态或动态LACP,使多个接口起到Load balance的作用,本例中实现从PC-101发包,经过208与207的中间链路(配置链路聚合,每个聚合口最多支持8个聚合成员),最终报文到达PC-91,且查看中间链路各接口收发包计数。

    1.1.1         拓扑

    1.1.2         静态LACP配置

    把208和207号机分别配置好接口,ge1为access模式,直连主机;ge47和ge48为静态聚合口,trunk模式;同在vlan2中。

    xNet#configure terminal

    xNet(config)#interface ge1

    xNet(config-if)#switchport

    xNet(config-if)#switchport mode access

    xNet(config-if)#switchport access vlan 2

    xNet(config-if)#exit

    xNet(config)#interface ge47

    xNet(config-if)#switchport

    xNet(config-if)#switchport mode trunk

    xNet(config-if)#switchport trunk allowed vlan add 2

    xNet(config-if)#static-channel-group 5

    xNet(config-if)#exit

    xNet(config)#interface ge48

    xNet(config-if)#switchport

    xNet(config-if)#switchport mode trunk

    xNet(config-if)#switchport trunk allowed vlan add 2

    xNet(config-if)#static-channel-group 5

    xNet(config-if)#end

    xNet#

    配置中把接口加入到static-channel-group 5当中,所以对应的聚合口为sa5,可用show命令查看sa5的配置:

    保存配置:

    1.1.3         静态LACP结果

    1)将PC-101构造大量报文,并通过交换机转发,目的MAC为PC-91号机的MAC,可以在207号机上查看是否学到PC-91号机MAC

    2)PC-101构造报文,为达到load balance效果,将报文源MAC为自增,聚合口默认是源MAC或目的MAC作load balance。

    3)结果显示,208号机的ge47和ge48的发送报文统计(速率与包数)几乎差不多,而207号机的接收报文统计也是一样。

    4)如果要配置load balance的策略,可以支持对源IP,目的IP,源MAC,目的MAC,分别作load balance,需要注意的是,构造的报文目的MAC一定要是交换机已学到的,未知的目的MAC不作load balance:

    xNet#configure terminal

    xNet(config)#interface sa5

    xNet(config-if)#port-channel load-balance ?

          

    1.1.4         动态LACP配置

    同样可对ge47和ge48配置成动态聚合,相连的两个接口,需要一端配置为active模式,另一端配置成passive模式,相应的动态聚合口为po口:

    xNet#con t

    xNet(config)#interface ge47

    xNet(config-if)#channel-group 4 mode active

    xNet(config-if)#exit

    xNet(config)#interface ge48

    xNet(config-if)#channel-group 4 mode passive

    xNet(config-if)#end

    xNet#

  • 相关阅读:
    动态代理方案性能对比(转载)
    Java类的初始化
    第78天:jQuery事件总结(一)
    第77天:jQuery事件绑定触发
    第76天:jQuery中的宽高
    第75天:jQuery中DOM操作
    第74天:jQuery实现图片导航效果
    第73天:jQuery基本动画总结
    第72天:jQuery实现下拉菜单
    第71天:jQuery基本选择器(二)
  • 原文地址:https://www.cnblogs.com/niezhongle/p/11075267.html
Copyright © 2011-2022 走看看