zoukankan      html  css  js  c++  java
  • 最长上升子序列

    http://acm.hdu.edu.cn/showproblem.php?pid=1069

    Monkey and Banana

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24641    Accepted Submission(s): 13209


    Problem Description
    A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

    The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

    Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
     
    Input
    The input file will contain one or more test cases. The first line of each test case contains an integer n,
    representing the number of different blocks in the following data set. The maximum value for n is 30.
    Each of the next n lines contains three integers representing the values xi, yi and zi.
    Input is terminated by a value of zero (0) for n.
     
    Output
    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
     
    Sample Input
    1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
     
    Sample Output
    Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
     
    Source
    #include <iostream>
    #include <memory.h>
    #include <string>
    #include <istream>
    #include <sstream>
    #include <vector>
    #include <stack>
    #include <algorithm>
    #include <map>
    #include <queue>
    #include <math.h>
    #include <cstdio>
    #include <set>
    #define ME(x , y) memset(x , y , sizeof(x))
    #define SF(n) scanf("%d" , &n)
    #define rep(i , n) for(int i = 0 ; i < n ; i ++)
    #define INF  0x3f3f3f3f
    #define mod 998244353
    #define PI acos(-1)
    using namespace std;
    typedef long long LL;
    int dp[189];
    
    struct node
    {
        int x , y , z ;
    }a[189];
    
    bool cmp(struct node a , struct node b)
    {
        if(a.x < b.x)
        {
            return 1 ;
        }
        else if(a.x == b.x)
        {
            return a.y < b.y ;
        }
        else return 0;
    }
    
    int main()
    {
        int n ;
        int cnt = 0 ;
        while(~scanf("%d" , &n) && n)
        {
            int l = 0 ;
            for(int i = 0 ; i < n ; i++)
            {
                int x , y , z ;
                scanf("%d%d%d" , &x , &y , &z);
                a[l].x = x , a[l].y = y , a[l++].z = z ;
                a[l].x = x , a[l].y = z , a[l++].z = y ;
                a[l].x = y , a[l].y = x , a[l++].z = z ;
                a[l].x = y , a[l].y = z , a[l++].z = x ;
                a[l].x = z , a[l].y = x , a[l++].z = y ;
                a[l].x = z , a[l].y = y , a[l++].z = x ;
            }
            sort(a , a+l , cmp);
            /*for(int i = 0 ; i < l ; i++)
            {
                cout << a[i].x << " " << a[i].y << " " << a[i].z << endl ;
            }*/
            for(int i = 0 ; i < l ; i++)
            {
                dp[i] = a[i].z ;
                for(int j = 0 ; j < i ; j++)
                {
                    if(a[j].x < a[i].x && a[j].y < a[i].y)
                    {
                        dp[i] = max(dp[i] , dp[j]+a[i].z);
                    }
                }
            }
            int ans = -INF ;
            for(int i = 0 ; i < l ; i++)
            {
                ans = max(ans , dp[i]);
            }
            cout << "Case " << ++cnt << ": maximum height = " << ans << endl;
        }
    
        return 0;
    }
  • 相关阅读:
    你所不知道的setTimeout
    SecureCRT8.1下载+注册机+破解教程
    jQuery学习
    GIt学习
    多进程
    Linux下的压缩(zip)解压(unzip)缩命令
    三次握手四次挥手
    django常见问题
    form和modelform
    文件上传
  • 原文地址:https://www.cnblogs.com/nonames/p/11729680.html
Copyright © 2011-2022 走看看