zoukankan      html  css  js  c++  java
  • 求高精度幂(poj1001)

    Description

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
    Input

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
    Output

    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.
    Sample Input

    95.123 12
    0.4321 20
    5.1234 15
    6.7592 9
    98.999 10
    1.0100 12
    Sample Output

    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201
    Hint

    If you don’t know how to determine wheather encounted the end of input:
    s is a string and n is an integer
    C++

    while(cin>>s>>n)

    {

    }

    c

    while(scanf(“%s%d”,s,&n)==2) //to see if the scanf read in as many items as you want

    /while(scanf(%s%d”,s,&n)!=EOF) //this also work /

    {

    }

    #include <iostream>  
    #include <string.h>  
    using namespace std;  
    int a[200];  
    int main()  
    {  
        int n,i,j;  
        string s;  
        while(cin>>s>>n)  
        {  
            memset(a,0,sizeof(a));  
            if(n == 0)  
            {  
                cout<<1<<endl;  
                continue;  
            }  
            bool flag = 1;  
            int pos = 0,base = 0,count = 0,bit = 1;  
            for(i = s.length()-1,j = 0; i >= 0; i--)  
            {  
                if(s[i] == '0'&&flag) count++;  
                else  
                {  
                    flag = 0;  
                    if(s[i] == '.')  
                    pos = s.length()-count-i-1;  
                    else  
                    {  
                        a[j++] = s[i] - '0';  
                        base += (s[i] - '0')*bit;  
                        bit *= 10;  
                    }  
    
                }  
            }  
            for(i = 0; i < n-1; i++)  
            {  
                int m = 0;  
                for(j = 0; j < 300; j++)  
                {  
                    m += base * a[j];  
                    a[j] = m % 10;  
                    m /= 10;  
                }  
            }  
            for(i = 299; a[i] == 0&&i > pos*n-1; i--);  
            while(i >= 0)  
            {  
                if(i == pos*n-1)  
                cout<<".";  
                cout<<a[i];  
                i--;  
            }  
            cout<<endl;  
        }  
        return 0;  
    }  
  • 相关阅读:
    IIS6的http.ini伪静态规则转换为IIS7伪静态规则的方法
    php ecshop 二级域名切换跳转时session不同步,解决session无法共享同步导致无法登陆的问题
    ECSHOP登录自动退出问题解决
    aspcms 分享到微信显示找不到模版的解决办法!
    ASPCMS内容调用去掉html标签
    凡是出现了问题,都是有原因存在的。
    spring下载地址
    比较好的资源
    xp系统下,安装github时,需要下载的补丁
    联合更新语句,根据photo中的数量更新相册表Num列
  • 原文地址:https://www.cnblogs.com/nyist-xsk/p/7264822.html
Copyright © 2011-2022 走看看