zoukankan      html  css  js  c++  java
  • Cable master POJ

    Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a “star” topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
    To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
    The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
    You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
    Input
    The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
    Output
    Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
    If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number “0.00” (without quotes).
    Sample Input
    4 11
    8.02
    7.43
    4.57
    5.39
    Sample Output
    2.00

    //给你n段电缆,然后给出一个k代表要求从n段截取的段数
    //然后让你从这n段电缆中截取等长度的电缆,问最大能截取的长度是多大
    #include<string>
    #include<stdio.h>
    #include<iomanip>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    typedef long long ll;
    
    int n,k;
    int a[10005];
    
    int judge(int x)
    {
        int sum=0;
        for(int i=0; i<n; i++)
            sum+=a[i]/x;
        if(sum>=k) return 1;
        else return 0;
    }
    int main()
    {
        while(~scanf("%d%d",&n,&k))
        {
            for(int i=0; i<n; i++)
            {
                double f;
                scanf("%lf",&f);
                a[i]=(int)(f*100);
            }
            sort(a,a+n);
            int high=a[n-1],low=1;
            while(low<=high)
            {
                int mid=(low+high)>>1;
                if(judge(mid)) low=mid+1;
                else high=mid-1;
            }
            cout<<fixed<<setprecision(2)<<(double)high/100.0<<endl;//fixed 和 setpriecision 连用可以控制输出
        }
        return 0;
    }
    
    
    
  • 相关阅读:
    最近的题越来越难了,卧槽,搞一上午一题不会,题解也看不懂
    hdu 4630 树状数组 ****
    hdu 3473 划分树 ***
    hdu 3360 最小点覆盖 **
    hdu 1507 记录路径的二分匹配 **
    poj 3177 边双联通 **
    hdu 4612 边双联通 ***
    Elasticsearch聚合后分页深入详解
    redis 五种数据类型及其使用场景
    再有人问你分布式锁,这篇文章扔给他
  • 原文地址:https://www.cnblogs.com/nyist-xsk/p/7264846.html
Copyright © 2011-2022 走看看