zoukankan      html  css  js  c++  java
  • 拯救007


    Saving James Bond - Easy Version

    This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

    Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

    Output Specification:

    For each test case, print in a line "Yes" if James can escape, or "No" if not.

    Sample Input 1:

    14 20
    25 -15
    -25 28
    8 49
    29 15
    -35 -2
    5 28
    27 -29
    -8 -28
    -20 -35
    -25 -20
    -13 29
    -30 15
    -35 40
    12 12
    

    Sample Output 1:

    Yes
    

    Sample Input 2:

    4 13
    -12 12
    12 12
    -12 -12
    12 -12
    

    Sample Output 2:

    No
    

    AC代码

    #include<iostream>
    #include<cmath>
    
    using namespace std;
    
    typedef pair<int, int> PII;
    
    const int N = 100;
    
    PII vertex[N];
    
    bool visited[N], flag;
    
    int n, D;
    
    bool isSafe(PII v)
    {
    	if (v.first == 0 && v.second == 0)
    		return D > 50 - 7.5;
    	return D >= 50 - abs(v.first) || D >= 50 - abs(v.second);
    }
    
    double distance(PII a, PII b) 
    {
    	return sqrt((a.first-b.first)*(a.first - b.first)+(a.second-b.second)*(a.second - b.second));
    }
    
    bool canJump(PII a, PII b)
    {
    	if (a.first == 0 && a.second == 0)
    		return D + 7.5 >= distance(a, b);
    	else
    		return D >= distance(a, b);
    }
    
    bool DFS(PII v)
    {
    	if (isSafe(v))
    		return true;
    	for (int i = 0; i < n; i++)
    	{
    		if (!visited[i] && canJump(v, vertex[i]))
    		{
    			visited[i] = true;
               // return DFS(vertex[i]);
    			flag = DFS(vertex[i]);
    			if (flag)
    				return true;
    		}
    	}
    	return false;
    }
    
    int main()
    {
    	cin >> n >> D;
    
    	for (int i = 0; i < n; i++)
    		scanf("%d%d", &vertex[i].first, &vertex[i].second);
    
    	if (DFS({ 0, 0 }))
    		cout << "Yes" << endl;
    	else
    		cout << "No" << endl;
    	system("pause");
    	return 0;
    }
    
  • 相关阅读:
    将数据加载时显示的图片和文字提成公共的--实现方法
    JavaScript【面向对象】-静态方法-私有方法-公有方法-特权方法
    强大的JS数组
    sql工作问题总结
    JSON.stringify()的使用--将string转换成json
    JS小技巧
    JS工作积累
    (六)Redis之数据结构之Set
    (五)Redis之List
    (四)Redis之哈希
  • 原文地址:https://www.cnblogs.com/optimjie/p/12677376.html
Copyright © 2011-2022 走看看