zoukankan      html  css  js  c++  java
  • 畅通工程

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 19396    Accepted Submission(s): 8246


    Problem Description
    省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。
     
    Input
    测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N
    行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。
     
    Output
    对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。
     
    Sample Input
    3 3
    1 2 1
    1 3 2
    2 3 4
    1 3
    2 3 2
    0 100
     
    Sample Output
    3
    ?
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #include<queue>
    using namespace std;
    int n,m,k;
    int u[5000],v[5000];
    int w[5000];
    int r[5000],p[105];
    int cmp(const int i,const int j)//对w[]间接排序
    {
        return w[i]<w[j];
    }
    void read_graph()//图存储
    {
        for(int i=0;i<n;++i)
        cin>>u[i]>>v[i]>>w[i];
    }
    int find(int x)//并查集查找函数
    {
        return p[x]==x?x:p[x]=find(p[x]);
    }
    void kruskal()
    {
        read_graph();
        for(int i=0;i<=m;++i) p[i]=i;
        for(int i=0;i<=n;++i) r[i]=i;
        sort(r,r+n,cmp);
        int ans=0;
        for(int i=0;i<n;++i){
            int e=r[i];
            int x=find(u[e]);
            int y=find(v[e]);
            if(x!=y) {ans+=w[e];p[y]=x;}
        }
        int cnt=0;
        for(int i=1;i<=m;++i) if(p[i]==i) cnt++;//计算连通分支个数
        if(cnt!=1) cout<<'?'<<endl;//连通分支数为1时才满足条件
        else  cout<<ans<<endl;
    }
    int main()
    {
        while(scanf("%d%d",&n,&m)&&n)
        kruskal();
        return 0;
    }
    
     
  • 相关阅读:
    正则表达式
    HDU 2066 多源最短路
    UVA 11039 模拟
    Concrete Mathematics Chapter 1 Warmups
    List differences between JAVA and C++
    uva 11107Life Forms
    poj 1509 Glass Beads
    poj 3581
    网络流建图
    图论算法----网络流
  • 原文地址:https://www.cnblogs.com/orchidzjl/p/4404240.html
Copyright © 2011-2022 走看看