zoukankan      html  css  js  c++  java
  • POJ 1251 Jungle Roads (最小生成树prim)


    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

    Input

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

    Output

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

    Sample Input

    9
    A 2 B 12 I 25
    B 3 C 10 H 40 I 8
    C 2 D 18 G 55
    D 1 E 44
    E 2 F 60 G 38
    F 0
    G 1 H 35
    H 1 I 35
    3
    A 2 B 10 C 40
    B 1 C 20
    0

    Sample Output

    216
    30
    题解:

      很水的题,直接套模板。需要注意的是输入格式,因为每行末尾可能会有多个空格。用cin输入就不用担心。
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    const int maxn=105,INF=1e9;
    int cost[maxn][maxn];
    int mincost[maxn];
    bool used[maxn];
    int n;
    int prim()
    {
        for(int i=0;i<n;i++)
        {
            mincost[i]=INF;
            used[i]=false;
        }
        mincost[0]=0;
        int res=0;
        while(666)
        {
            int v=-1;
            for(int u=0;u<n;u++)
            {
                if(!used[u]&&(v==-1||mincost[u]<mincost[v]))
                    v=u;
            }
            if(v==-1)
                break;
            used[v]=true;
            res+=mincost[v];
            for(int u=0;u<n;u++)
                mincost[u]=min(mincost[u],cost[v][u]);
        }
        return res;
    }
    int main()
    {
        while(cin>>n,n)
        {
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++)
                    cost[i][j]=INF;
            for(int i=0;i<n-1;i++)
            {    
                char u;
                int k;
                cin>>u>>k;
                while(k--)
                {
                    char v;
                    int val;
                    cin>>v>>val;
                    cost[u-'A'][v-'A']=cost[v-'A'][u-'A']=val;
                }
            }    
            cout<<prim()<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    [WPF VTK]三维图形开发基础(一)
    WP开发(一)
    [WPF VTK]三维图形开发基础(四)

    WIN8 下IE突然无法打开(管理员权限可打开)
    [WPF VTK]三维图形开发基础(三)
    堆排序、快排的坑
    双向链表之插入
    [WPF VTK]三维图形开发基础(二)
    [转载]Android界面设计学习日志(一)
  • 原文地址:https://www.cnblogs.com/orion7/p/7373756.html
Copyright © 2011-2022 走看看