zoukankan      html  css  js  c++  java
  • UVA 1359 POJ 3522 Slim Span(最小生成树kruskal)

    Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

    The graph G is an ordered pair (VE), where V is a set of vertices {v1v2, …, vn} and E is a set of undirected edges {e1e2, …, em}. Each edge e ∈ E has its weight w(e).

    A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.

     
    Figure 5: A graph G and the weights of the edges

    For example, a graph G in Figure 5(a) has four vertices {v1v2v3v4} and five undirected edges {e1e2e3e4e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

     
    Figure 6: Examples of the spanning trees of G

    There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees TbTc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

    Your job is to write a program that computes the smallest slimness.

    Input

    The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

    n m  
    a1 b1 w1
       
    am bm wm

    Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ekwk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (VE) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

    Output

    For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

    Sample Input

    4 5
    1 2 3
    1 3 5
    1 4 6
    2 4 6
    3 4 7
    4 6
    1 2 10
    1 3 100
    1 4 90
    2 3 20
    2 4 80
    3 4 40
    2 1
    1 2 1
    3 0
    3 1
    1 2 1
    3 3
    1 2 2
    2 3 5
    1 3 6
    5 10
    1 2 110
    1 3 120
    1 4 130
    1 5 120
    2 3 110
    2 4 120
    2 5 130
    3 4 120
    3 5 110
    4 5 120
    5 10
    1 2 9384
    1 3 887
    1 4 2778
    1 5 6916
    2 3 7794
    2 4 8336
    2 5 5387
    3 4 493
    3 5 6650
    4 5 1422
    5 8
    1 2 1
    2 3 100
    3 4 100
    4 5 100
    1 5 50
    2 5 50
    3 5 50
    4 1 150
    0 0

    Sample Output

    1
    20
    0
    -1
    -1
    1
    0
    1686
    50
    题意:
      给出一个n个结点的无向图,找一棵苗条度(最大边减去最小边)最小的生成树。图中不含重边和自环。
    题解:
      
      首先对边的权值大小排序,从小到大开始枚举最小生成树。
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    const int maxn=105,INF=1e9;
    int n,m;
    int par[maxn];
    struct edge
    {
        int u,v,cost;
    }es[maxn*maxn];
    bool cmp(const edge& a,const edge& b)
    {
        return a.cost<b.cost;
    }
    int find(int x)
    {
        return x==par[x]?x:par[x]=find(par[x]);
    }
    void init()
    {
        for(int i=1;i<=n;i++)
            par[i]=i;
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x!=y)
            par[x]=y;
    }
    bool same(int x,int y)
    {
        return find(x)==find(y);
    }
    int kruskal(int a)
    {
        int cnt=0,Max;
        init();
        for(int i=a;i<m;i++)
        {
            edge e=es[i];
            if(!same(e.u,e.v))
            {
                cnt++;
                unite(e.u,e.v);
                if(cnt==n-1)
                    Max=e.cost;
            }
        }
        if(cnt==n-1)
            return Max-es[a].cost;
        return INF;
    }
    int main()
    {
        while(cin>>n>>m,n||m)
        {
            for(int i=0;i<m;i++)
                scanf("%d%d%d",&es[i].u,&es[i].v,&es[i].cost);
            if(m<n-1)
            {
                cout<<"-1"<<endl;
                continue;
            }
            sort(es,es+m,cmp);
            int ans=INF;
            for(int i=0;i<=m-n+1;i++)
                ans=min(ans,kruskal(i));
            if(ans==INF)
                cout<<"-1"<<endl;
            else
                cout<<ans<<endl;
        }
        return 0;
    }
    
    
    
     
  • 相关阅读:
    双主MySQL+keepalived高可用配置
    centos6.8服务器部署svn
    Centos6下rpm安装MySQL5.6
    CentOS6.8下部署Zabbix3.0
    python核心编程第六章练习6-15
    python核心编程第六章练习6-14
    scp 将数据从一台linux服务器复制到另一台linux服务器
    $config['base_url'] BASE_URL
    ubunt设置终端快捷键设置 及 常用快捷键
    URL 路由
  • 原文地址:https://www.cnblogs.com/orion7/p/7395951.html
Copyright © 2011-2022 走看看