zoukankan      html  css  js  c++  java
  • POJ 3617 Best Cow Line(贪心 字典序最小)

    FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

    The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

    FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

    FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

    Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

    Input

    * Line 1: A single integer: N
    * Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

    Output

    The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

    Sample Input

    6
    A
    C
    D
    B
    C
    B

    Sample Output

    ABCBCD

    题意:
      给定长度为n的字符串S,要构造一个长度为N的字符串T。起初,T是一个空串,反复进行下列两种操作。
      从S的头部删除一个字符,加到T的尾部。
      从S的尾部删除一个字符,加到T的尾部。
      要求T的字典序最小。(字典序是从前到后比较两个字符的方法。首先比较两个的第一个字符,如果不同,则较小的字符较小的字符串的字典序最小。如果相同则比较第2个字符...直到比出大小为止。)
    题解:
      贪心的选取S的开头或者末尾较小的字符放到T的末尾。但是,如果开头末尾的字符相同的话,该如何选取呢?这个时候贪心的思想就是要尽早的选取使用更小的字符,那么就要比较下一个字符的大小。
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    using namespace std;
    int n;
    char s[2005];
    void solve()
    {
        int a=0,b=n-1;
        int cnt=0;
        while(a<=b)
        {
            bool left=false;
            for(int i=0;a+i<=b;i++)
            {
                if(s[a+i]<s[b-i])
                {
                    left=true;
                    break;
                }
                else if(s[a+i]>s[b-i])
                {
                    left=false;
                    break;
                }
            }       
            if(left)
                putchar(s[a++]);
            else
                putchar(s[b--]);
            if(++cnt%80==0)
                putchar('
    ');
        }
    }
    int main()
    {
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>s[i];
        solve();
        return 0;
    }
    
    
    

      
  • 相关阅读:
    匿名函数
    Python基础练习题5
    for循环实现一个注册小案例
    Python基础练习题4
    Python集合
    Python基础练习题3
    Python 元组和字典
    Python PEP8规范与python之禅
    Python基础练习题2
    常见的排序之冒泡排序
  • 原文地址:https://www.cnblogs.com/orion7/p/7445444.html
Copyright © 2011-2022 走看看