zoukankan      html  css  js  c++  java
  • POJ 3186 Treats for the Cows (简单区间DP)

    FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

    The treats are interesting for many reasons:
    • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
    • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
    • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
    • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
    Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

    The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

    Input

    Line 1: A single integer, N 

    Lines 2..N+1: Line i+1 contains the value of treat v(i)

    Output

    Line 1: The maximum revenue FJ can achieve by selling the treats

    Sample Input

    5
    1
    3
    1
    5
    2

    Sample Output

    43

    Hint

    Explanation of the sample: 

    Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

    FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
    题意:
       第n次从序列的头部或者尾部取一个数a[i],求n*a[i]累加和。
     
    题解:
      很容易想到贪心地前面选取尽量小的数,但是仔细考虑是不行的。前面的选择会对后面的选择产生影响,这时就应该想到DP了。这类问题属于区间DP。假设dp[i][j]是区间[i,j]上的最大值,那么区间dp[i][j]可以由dp[i+1][j]选取a[i]或者dp[i][j-1]选取a[j]得到。但是我们直接dp是不好做的,需要从区间长度入手。具体实现请看代码。
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    int a[2005];
    int dp[2005][2005];
    int main()
    {
        int n;
        while(cin>>n)
        {
            for(int i=1;i<=n;i++)
                cin>>a[i],dp[i][i]=a[i]*n;//区间长度为1的时候,当然是最后一个取。
            for(int len=1;len<n;len++)//枚举区间长度
                for(int i=1;i+len<=n;i++)//枚举区间的起点
                {
                    int j=i+len;//区间的终点
                    dp[i][j]=max(dp[i+1][j]+(n-len)*a[i],dp[i][j-1]+(n-len)*a[j]);
                }
            cout<<dp[1][n]<<endl;//答案就是1到n这个区间的最大值
        }
        return 0;
    }
  • 相关阅读:
    Docker和K8S
    CoBot 库博源代码缺陷检测工具
    Hobot软件成分分析平台
    Black duck(黑鸭子软件)开源代码审计管理测试平台
    python之理解super及MRO列表
    Python中MRO排序原理
    python中with的用法
    使用微服务架构重构支付网关
    支付网关的设计原则
    python内存管理--垃圾回收
  • 原文地址:https://www.cnblogs.com/orion7/p/7468768.html
Copyright © 2011-2022 走看看