zoukankan      html  css  js  c++  java
  • POJ 3262 Protecting the Flowers (贪心)

    Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

    Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

    Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

    Input
    Line 1: A single integer N
    Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics
    Output
    Line 1: A single integer that is the minimum number of destroyed flowers
    Sample Input
    6
    3 1
    2 5
    2 3
    3 2
    4 1
    1 6
    Sample Output
    86
    Hint
    FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.

    题意:

    保护花朵:FJ的奶牛每分钟吃掉D_i朵花,把它赶走需要T_i分钟(来回加倍)。问最小损失花朵数量。

    题解:

    贪心选取赶走奶牛需要花费花朵数量最多的奶牛。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxn=1e5+5;
    typedef long long LL;
    struct cow
    {
        int t,cost;
        bool operator <(const cow& a) const
        {
            return cost*a.t>t*a.cost;//赶走一只奶牛需要花费花朵的数量,从大到小
        }
    }c[maxn];
    int main()
    {
        int n;
        cin>>n;
        LL sum=0;
        for(int i=0;i<n;i++)
        {
            cin>>c[i].t>>c[i].cost;
            sum+=c[i].cost;
        }
        sort(c,c+n);
        LL ans=0;
        for(int i=0;i<n-1;i++)
        {
            sum-=c[i].cost;
            ans+=2*sum*c[i].t;
        }
        cout<<ans<<endl;
        return 0;
    }
    
  • 相关阅读:
    练习10.9-2
    [转]JVM 内存初学 (堆(heap)、栈(stack)和方法区(method) )
    JAVA成员变量为什么不能在类体中先定义后赋值
    core image几个滤镜样例 oc版本号和swift版本号
    UVa 11997 K Smallest Sums 优先队列&amp;&amp;打有序表&amp;&amp;归并
    Android基础新手教程——4.4.1 ContentProvider初探
    Restore IP Addresses -- LeetCode
    Android中Intent传递类对象的方法一(Serializable)
    Effective C++:条款22:将成员变量声明为private
    javascript cookie
  • 原文地址:https://www.cnblogs.com/orion7/p/7822837.html
Copyright © 2011-2022 走看看