zoukankan      html  css  js  c++  java
  • HDU 1564 Play a game (简单博弈)

    New Year is Coming!
    ailyanlu is very happy today! and he is playing a chessboard game with 8600.
    The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?
    Input
    The input is a sequence of positive integers each in a separate line.
    The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.
    Output
    Output the winner ("8600" or "ailyanlu") for each input line except the last zero.
    No other characters should be inserted in the output.
    Sample Input
    2
    0
    Sample Output
    8600

    题意:

    从棋盘的一角开始,每人每次只能移动棋子到相邻没有经过的位置,直到不能移动棋子则为输。

    题解:

    很简单的博弈,也很好想,N为奇偶输赢不一样。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    typedef long long LL;
    int main()
    {
        int n;
        while(cin>>n,n)
        {
            if(n%2)
                cout<<"ailyanlu"<<endl;
            else
                cout<<"8600"<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    Python 集合 深浅copy
    python基础(基础数据类型)
    python基础一
    Asp.net获取网站绝对路径的几种方法
    Ajax请求被缓存的几种处理方式
    说说字符编码
    linux学习记录
    mysql基础
    【Android开发入门】关于ListView中按钮监听器设置的解决方案
    线程同步小结
  • 原文地址:https://www.cnblogs.com/orion7/p/7930529.html
Copyright © 2011-2022 走看看