zoukankan      html  css  js  c++  java
  • POJ 3061 Subsequence (二分||尺取法)

    A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
    Input
    The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
    Output
    For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
    Sample Input
    2
    10 15
    5 1 3 5 10 7 4 9 2 8
    5 11
    1 2 3 4 5
    Sample Output
    2
    3

    题意:

    求出总和不小于S的连续子序列的长度的最小值。

    题解:

    二分查找的话,前缀和是满足单调性的,计算从每一个数开始总和刚好大于s的长度。具体实现就是
    二分搜索s[i]+s是否存在于前缀和数组中,就是查找以i+1开头的总和刚好大于s的最短长度。

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    const int maxn=1e5+5;
    int sum[maxn];
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            int n,S;
            cin>>n>>S;
            for(int i=0;i<n;i++)
            {
                int x;
                cin>>x;
                sum[i+1]=sum[i]+x;
            }
            if(sum[n]<S)
            {
                puts("0");
                continue;
            }
            int res=n;
            for(int s=0;sum[s]+S<=sum[n];s++)
            {
                int t=lower_bound(sum+s,sum+n,sum[s]+S)-sum;
                res=min(res,t-s);
            }
            cout<<res<<endl;
        }
        return 0;
    }
    

    解法二:尺取法
    反复地推进区间的开头和末尾,来求取条件的最小区间的方法被称为尺取法。
    因为很懒,所以直接贴图片了。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxn=1e5+5;
    int a[maxn];
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            int n,k;
            cin>>n>>k;
            int s=0,t=0,sum=0;
            for(int i=0;i<n;i++)
                cin>>a[i];
            int res=n+1;
            for(;;)
            {
                while(t<n&&sum<k)
                    sum+=a[t++];
                if(sum<k)
                    break;
                res=min(res,t-s);
                sum-=a[s++];
            }
            if(res>n)
                res=0;
            cout<<res<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    深入浅出JMS(二)--ActiveMQ简单介绍以及安装
    redis学习
    浏览器的渲染过程
    http请求
    常用正则表达式
    js继承的几种实现方式
    js中的浅拷贝和深拷贝
    webpack常用的plugin
    linux基本命令
    webpack压缩代码组件uglifyjs-webpack-plugin
  • 原文地址:https://www.cnblogs.com/orion7/p/8017177.html
Copyright © 2011-2022 走看看