zoukankan      html  css  js  c++  java
  • 利用递归实现数列的全排列(HDU 1027)

    #include<iostream>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    const int INF=0x3f3f3f3f;
    const int maxn=10005;
    int perm[maxn];
    bool used[maxn];
    int n;
    void permutation(int pos,int n)
    {
        if(pos==n+1)//排列完毕,打印
        {
            for(int i=1;i<n;i++)
                cout<<perm[i]<<' ';
            cout<<perm[n]<<endl;
            return ;
        }
        for(int i=1;i<=n;i++)//数列的第pos个位置,用第1~n个的哪一个进行循环
        {
            if(!used[i])
            {
                perm[pos]=i;
                used[i]=true;//i被使用了,标记为true
                permutation(pos+1,n);
                used[i]=false;//返回后要复位
            }
        }
        return ;
    }
    int main()
    {
        int n;
        while(cin>>n)
        {
            for(int i=1;i<=n;i++)
                perm[i]=i;
            permutation(1,n);
        }
        return 0;
    }
    

    附上HDOJ上的一道题:

    Ignatius and the Princess II

    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?
    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
    Sample Input
    6 4
    11 8
    Sample Output
    1 2 3 5 6 4
    1 2 3 4 5 6 7 9 8 11 10

    题意

    输出字典序第k小的数列。

    题解

    可以如上使用递归法,或者直接调用函数库里的next_permutation函数。
    
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    const int INF=0x3f3f3f3f;
    const int maxn=10005;
    int perm[maxn];
    bool used[maxn];
    int n,k;
    int cnt;
    bool flag;
    void permutation(int pos,int n)
    {
        if(pos==n+1)//排列完毕
        {
            if(++cnt==k)
                flag=true;   
            return ;
        }
        for(int i=1;i<=n;i++)//数列的第pos个位置,用第1~n个的哪一个进行循环
        {
            if(!used[i])
            {
                perm[pos]=i;
                used[i]=true;//i被使用了,标记为true
                permutation(pos+1,n);
                if(flag)
                    return ;
                used[i]=false;//返回后要复位
            }
        }
        return ;
    }
    int main()
    {
        while(cin>>n>>k)
        {
            flag=false;
            memset(used,false,sizeof(used));
            cnt=0;
            for(int i=1;i<=n;i++)
                perm[i]=i;
            permutation(1,n);
            for(int i=1;i<n;i++)
                cout<<perm[i]<<' ';
            cout<<perm[n]<<endl;
        }
        return 0;
    }
    

    用函数库里的next_permutation函数

    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    const int INF=0x3f3f3f3f;
    typedef long long LL;
    const int maxn=10005;
    int a[maxn];
    int main()
    {
        int n,k;
        while(cin>>n>>k)
        {
            for(int i=1;i<=maxn;i++)
                a[i]=i;
            for(;--k;)
                next_permutation(a+1,a+1+n);
            for(int i=1;i<n;i++)
                cout<<a[i]<<' ';
            cout<<a[n]<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    20175226 2018-2019-2 《Java程序设计》第二周学习总结
    存储管理-页面置换算法(页面淘汰算法)
    存储管理-存储组织
    进程管理-死锁问题
    操作系统-进程管理
    操作系统:进程管理、存储管理、文件管理、作业管理、设备管理
    第十一章 集合框架
    匿名内部类
    第10章 java常用类
    第8章 反射
  • 原文地址:https://www.cnblogs.com/orion7/p/8444394.html
Copyright © 2011-2022 走看看