zoukankan      html  css  js  c++  java
  • 学点c++

    描述现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);

    1.按照编号从小到大排序

    2.对于编号相等的长方形,按照长方形的长排序;

    3.如果编号和长都相同,按照长方形的宽排序;

    4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;

     
    输入
    第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
    每一组第一行有一个整数 0<m<1000,表示有m个长方形;
    接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,

    第二个和第三个数值大的表示长,数值小的表示宽,相等
    说明这是一个正方形(数据约定长宽与编号都小于10000);
    输出
    顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
    样例输入
    1
    8
    1 1 1
    1 1 1
    1 1 2
    1 2 1
    1 2 2
    2 1 1
    2 1 2
    2 2 1
    
    样例输出
    1 1 1
    1 2 1
    1 2 2
    2 1 1
    2 2 1
    #include<iostream>
    #include<string>
    #include<list>
    #include<algorithm>
    using namespace std;
    
    class retangle
    {
        private:
            int a,b,c;
        public:
            retangle(int a1,int b1,int c1):a(a1){
                if(b1>c1){b=b1,c=c1;}
                else {b=c1,c=b1;}
            };
            friend ostream& operator << (ostream &out,const retangle &r)
            {
                out<<r.a<<" "<<r.b<<" "<<r.c<<endl;
           return out; } friend
    bool operator <(const retangle &x,const retangle &y) { if(x.a!=y.a)return x.a < y.a; if(x.b!=y.b)return x.b < y.b; if(x.c!=y.c)return x.c < y.c; } friend bool operator ==(const retangle &x,const retangle &y) { if(x.a==y.a&&x.b==y.b&&x.c==y.c)return true; return false; } }; int main() { int n; cin>>n; while(n--) { int m; cin>>m; list<retangle> st; while(m--) { int a,b,c; cin>>a>>b>>c; st.push_back(retangle(a,b,c)); st.sort(); st.unique(); } while(!st.empty()){ cout<<st.front(); st.pop_front(); } } return 0; }
  • 相关阅读:
    Git使用基础介绍
    [SnowflakeIdWorker]雪花Id
    C#[反射 Reflection]
    [.Net Core]Castle DynamicProxy
    [Vue]Vuex
    [Vue] 导航守卫
    [Vue] $route和$router的区别
    Unexpected end of JSON input while parsing near '..."
    推荐一款截图的工具(Snip)
    [Vue] 计算属性Computed与函数function的异同
  • 原文地址:https://www.cnblogs.com/p-c-/p/4209499.html
Copyright © 2011-2022 走看看