zoukankan      html  css  js  c++  java
  • Integer Inquiry_hdu_1047(大数).java

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9376    Accepted Submission(s): 2406

    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
     
    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

    The final input line will contain a single zero on a line by itself.
     
    Output
    Your program should output the sum of the VeryLongIntegers given in the input. 


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     
    Sample Input
    1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
     
    Sample Output
    370370367037037036703703703670
     
    Source
     

    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {//没咋看懂是怎么输入的
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		while(input.hasNext()){
    			int n=input.nextInt();
    			while(n-->0){
    				BigInteger sum=BigInteger.valueOf(0);
    				BigInteger a;
    				while(!(a=input.nextBigInteger()).equals(BigInteger.valueOf(0))){
    					sum=sum.add(a);
    				}
    				System.out.println(sum);
    				if(n>0)
    					System.out.println();
    			}
    		}
    	}
    }


  • 相关阅读:
    祖国,让我为您写首歌
    提升信任度,是做网络营销成功的必由之路
    名字作诗已成流行语,你“OUT”了吧?
    腾飞天涯
    沈阳首个文化强市评价体系出炉,为沈阳文化振兴打分
    寄语“官员诗人”车延高:我挺你
    “自己选的路,就算跪着也要走完”引热议
    我在月光下想你
    国庆献礼谁为重
    gcc和g++的区别
  • 原文地址:https://www.cnblogs.com/pangblog/p/3253556.html
Copyright © 2011-2022 走看看