zoukankan      html  css  js  c++  java
  • 【PAT】1024. Palindromic Number (25)

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

    Input Specification:

    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

    Output Specification:

    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

    Sample Input 1:
    67 3
    
    Sample Output 1:
    484
    2
    
    Sample Input 2:
    69 3
    
    Sample Output 2:
    1353
    3
    


    分析:简单题。判断回文串。

    #include<iostream>
    #include<vector>
    #include<string.h>
    using namespace std;
    
    bool isPalindromic(vector<int> a)
    {
    	int i,j;
    	bool flag = true;
    	for(i=0,j=a.size()-1; i<=j; i++,j--){
    		if(a[i] != a[j]){
    			flag = false;
    			break;
    		}
    	}
    	return flag;
    }
    
    void show(vector<int> input)
    {
    	int i;
    	for(i=input.size()-1; i>=0; i--)
    	{
    		cout<<input[i];
    	}
    	cout<<endl;
    }
    
    int main()
    {
    	vector<int> input;
    	int k;
    	char s[11];
    	scanf("%s %d",s,&k);
    
    	int len = strlen(s);
    	int i;
    	for(i=0; i<len; i++)
    		input.push_back(s[i] - '0');
    
    	if(isPalindromic(input))
    	{
    		show(input);  //输出
    		cout<<"0"<<endl;
    	}
    	else
    	{
    		int len_temp = len;
    		for(i=1; i<=k; i++){
    			int t = 0;
    			int end = len_temp - 1;
    			int	start = 0;
    			int j = 0;
    			vector<int> vec_temp;
    			for(; start<len_temp && end>=0; start++,end--,j++){
    				vec_temp.push_back(t + input[start] + input[end]);
    				if(vec_temp[j] >= 10){
    					vec_temp[j] -= 10;
    					t = 1;
    				}
    				else
    					t = 0;
    			}
    			if(t > 0)
    				vec_temp.push_back(1);
    			len_temp = vec_temp.size();
    			input.assign(vec_temp.begin(),vec_temp.end());
    			if(isPalindromic(input))
    				break;
    		}
    		show(input);
    		if(i>k) cout<<k<<endl;
    		else
    			cout<<i<<endl;
    	}	
    	return 0;
    }


  • 相关阅读:
    UDP
    ICMP协议、DNS、ARP协议、ping、DHCP协议
    OSI七层模型和TCP/IP四层模型
    STL六大组件
    迭代器
    哈希表
    react wangeditor使用
    URL切割
    ES6对象合并
    nginx 访问本机文件
  • 原文地址:https://www.cnblogs.com/pangblog/p/3398066.html
Copyright © 2011-2022 走看看