zoukankan      html  css  js  c++  java
  • POJ 1852 Ants

    Ants
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 15617   Accepted: 6753

    Description

    An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

    Input

    The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

    Output

    For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

    Sample Input

    2
    10 3
    2 6 7
    214 7
    11 12 7 13 176 23 191
    

    Sample Output

    4 8
    38 207

    白书上有类似的题目....一开始想分开讨论...想了想可以合在一起写。

    最小的滑落时间就是  最小里面的最大值

    最大的滑落时间就是  最大里面的最大值

    /* ***********************************************
    Author        :guanjun
    Created Time  :2016/10/29 19:34:19
    File Name     :poj1852.cpp
    ************************************************ */
    #include <iostream>
    #include <stdio.h>
    #include <algorithm>
    #define ull unsigned long long
    #define ll long long
    #define mod 90001
    #define INF 0x3f3f3f3f
    #define maxn 10010
    #define cle(a) memset(a,0,sizeof(a))
    
    using namespace std;
    
    int n,l;
    int a[1001000];
    int main()
    {
        #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        #endif
        //freopen("out.txt","w",stdout);
        int t;
        cin>>t;
        while(t--){
            scanf("%d %d",&l,&n);
            for(int i=1;i<=n;i++)scanf("%d",&a[i]);
            int Max=0;
            int Min=0;
            for(int i=1;i<=n;i++){
                Min=max(Min,min(a[i],l-a[i]));
                Max=max(Max,max(a[i],l-a[i]));
            }
            cout<<Min<<" "<<Max<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Js如何动态声明变量名
    vue 生命周期
    开心就要说出来
    为你自己而努力
    vue调试工具
    笨笨对面向对象的理解
    一些小知识点-慢慢更新
    Ajax同时上传表单序列化参数+自定义参数
    关闭layer当前弹窗
    JSTL 递增序号
  • 原文地址:https://www.cnblogs.com/pk28/p/6036673.html
Copyright © 2011-2022 走看看