zoukankan      html  css  js  c++  java
  • poj--1258--Agri-Net(最小生成树)

    Time Limit: 1000MS   Memory Limit: 10000KB   64bit IO Format: %I64d & %I64u

    Status

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
    The distance between any two farms will not exceed 100,000.

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28
    
    
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,pre[10010];
    struct node
    {
    	int u,v;
    	int val;
    }edge[10010];
    int cmp(node s1,node s2)
    {
    	return s1.val<s2.val;
    }
    int find(int x)
    {
    	return pre[x]==x?pre[x]:(pre[x]=find(pre[x]));
    }
    int main()
    {
    	while(cin>>n)
    	{
    		int cnt=0;
    		for(int i=1;i<=n;i++)
    		for(int j=1;j<=n;j++)
    		{
    			int val;
    			cin>>val;
    			if(i==j) continue;
    			edge[cnt].u=i,edge[cnt].v=j,edge[cnt++].val=val;
    		}
    		sort(edge,edge+cnt,cmp);
    		int sum=0;
    		memset(pre,-1,sizeof(pre));
    		for(int i=0;i<=cnt;i++)
    		pre[i]=i;
    		for(int i=0;i<cnt;i++)
    		{
    			int fx=find(edge[i].u);
    			int fy=find(edge[i].v);
    			if(fx!=fy)
    			{
    				pre[fx]=fy;
    				sum+=edge[i].val;
    			}
    			
    		}
    		cout<<sum<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    云架构师进阶攻略(3)
    微服务化之服务拆分与服务发现
    终于有人把云计算、大数据和人工智能讲明白了!(1)
    JavaScript的数组详解
    html中给元素添加背景图片或者gif动图
    JavaScript的事件
    JavaScript的匿名函数
    JavaScript获取和操作html的元素
    JavaScript的条件运算符与条件语句
    JavaScript变量、数据类型、函数
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273446.html
Copyright © 2011-2022 走看看