zoukankan      html  css  js  c++  java
  • Ice_cream’s world III

    Ice_cream’s world III

    Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 10   Accepted Submission(s) : 3
    Problem Description
    ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
     

    Input
    Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
     

    Output
    If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
     

    Sample Input
    2 1 0 1 10 4 0
     

    Sample Output
    10 impossible
     

    Author
    Wiskey
     

    Source
    HDU 2007-10 Programming Contest_WarmUp


    #include<stdio.h>
    #include<string.h>
    #define INF 0xfffffff
    int map[1010][1010],v[10001];
    int main()
    {
    	int n,m;
    	while(scanf("%d%d",&n,&m)!=EOF)
    	{
    		int i,j,min,flag=0,sum=0;
    		memset(v,0,sizeof(v));
    		for(i=0;i<=1001;i++)
    		{
    			for(j=0;j<=1001;j++)
    				map[i][j]=INF;
    		}
    		while(m--)
    		{
    			int a,b,c;
    			scanf("%d%d%d",&a,&b,&c);
    			if(c<map[a][b])
    				map[a][b]=map[b][a]=c;
    		}
    		v[0]=1;
    		for(i=1;i<n;i++)
    		{
    			min=INF;
    			flag=0;
    			for(j=0;j<n;j++)
    			{
    				if(!v[j]&&map[0][j]<min)
    				{
    					min=map[0][j];
    					flag=j;
    				}
    			}
    			if(!flag)
    				break;
    			sum+=map[0][flag];
    			v[flag]=1;
    			for(j=0;j<n;j++)
    			{
    				if(!v[j]&&map[0][j]>map[flag][j])
    					map[0][j]=map[flag][j];
    			}
    		}
    		if(i==n)
    			printf("%d
    
    ",sum);
    		else
    			printf("impossible
    
    ");
    	}
    }


  • 相关阅读:
    2016CCPC东北地区大学生程序设计竞赛 1003 HDU5924
    2016CCPC东北地区大学生程序设计竞赛 1001 HDU5922
    Codeforces Round #375 (Div. 2) D
    linux开发缩写
    unity实现玻璃效果
    商业智能在公安交通管理领域的应用
    unity shaderlab Blend操作
    某中国500强企业BI系统成功应用案例
    Unity 5.X扩展编辑器之打包assetbundle
    unity描边效果
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273841.html
Copyright © 2011-2022 走看看