zoukankan      html  css  js  c++  java
  • [USACO10MAR]伟大的奶牛聚集Great Cow Gat…

    一道很好的树形dp啊

    思路:先从1号点dfs,维护出f[i](表示以i为根的子树所有点到i的值,tot[i](表示以i为根的子树中牛的个数

    在进行一次dfs,这次就用动态规划的思想:dp[v]=dp[u]-tot[v]*e[i].w+(cnt-tot[v])*e[i].w;(为什么呢,好好想想)

    v是u的儿子,表示将v的子节点减去u到v的长度加上剩余牛数目的加上u到v的长度

    题目描述

    Bessie is planning the annual Great Cow Gathering for cows all across the country and, of course, she would like to choose the most convenient location for the gathering to take place.

    Bessie正在计划一年一度的奶牛大集会,来自全国各地的奶牛将来参加这一次集会。当然,她会选择最方便的地点来举办这次集会。

    Each cow lives in one of N (1 <= N <= 100,000) different barns (conveniently numbered 1..N) which are connected by N-1 roads in such a way that it is possible to get from any barn to any other barn via the roads. Road i connects barns A_i and B_i (1 <= A_i <= N; 1 <= B_i <= N) and has length L_i (1 <= L_i <= 1,000). The Great Cow Gathering can be held at any one of these N barns. Moreover, barn i has C_i (0 <= C_i <= 1,000) cows living in it.

    每个奶牛居住在 N(1<=N<=100,000) 个农场中的一个,这些农场由N-1条道路连接,并且从任意一个农场都能够到达另外一个农场。道路i连接农场A_i和B_i(1 <= A_i <=N; 1 <= B_i <= N),长度为L_i(1 <= L_i <= 1,000)。集会可以在N个农场中的任意一个举行。另外,每个牛棚中居住者C_i(0 <= C_i <= 1,000)只奶牛。

    When choosing the barn in which to hold the Cow Gathering, Bessie wishes to maximize the convenience (which is to say minimize the inconvenience) of the chosen location. The inconvenience of choosing barn X for the gathering is the sum of the distances all of the cows need to travel to reach barn X (i.e., if the distance from barn i to barn X is 20, then the travel distance is C_i*20). Help Bessie choose the most convenient location for the Great Cow Gathering.

    在选择集会的地点的时候,Bessie希望最大化方便的程度(也就是最小化不方便程度)。比如选择第X个农场作为集会地点,它的不方便程度是其它牛棚中每只奶牛去参加集会所走的路程之和,(比如,农场i到达农场X的距离是20,那么总路程就是C_i*20)。帮助Bessie找出最方便的地点来举行大集会。

    Consider a country with five barns with [various capacities] connected by various roads of varying lengths. In this set of barns, neither barn 3 nor barn 4 houses any cows.

    1 3 4 5

    @--1--@--3--@--3--@[2]

    [1] |

    2 | @[1] 2 Bessie can hold the Gathering in any of five barns; here is the table of inconveniences calculated for each possible location:

    Gather ----- Inconvenience ------

    Location B1 B2 B3 B4 B5 Total

    1 0 3 0 0 14 17

    2 3 0 0 0 16 19

    3 1 2 0 0 12 15

    4 4 5 0 0 6 15

    5 7 8 0 0 0 15

    If Bessie holds the gathering in barn 1, then the inconveniences from each barn are:

    Barn 1 0 -- no travel time there!

    Barn 2 3 -- total travel distance is 2+1=3 x 1 cow = 3 Barn 3 0 -- no cows there!

    Barn 4 0 -- no cows there!

    Barn 5 14 -- total travel distance is 3+3+1=7 x 2 cows = 14 So the total inconvenience is 17.

    The best possible convenience is 15, achievable at by holding the Gathering at barns 3, 4, or 5.

    输入输出格式

    输入格式:

    * Line 1: A single integer: N

    * Lines 2..N+1: Line i+1 contains a single integer: C_i

    * Lines N+2..2*N: Line i+N+1 contains three integers: A_i, B_i, and L_i

    第一行:一个整数 N 。

    第二到 N+1 行:第 i+1 行有一个整数 C_i

    第 N+2 行到 2*N 行:第 i+N+1 行为 3 个整数:A_i,B_i 和 L_i。

    输出格式:

    * Line 1: The minimum inconvenience possible

    第一行:一个值,表示最小的不方便值。

    输入输出样例

    输入样例#1: 复制
    5 
    1 
    1 
    0 
    0 
    2 
    1 3 1 
    2 3 2 
    3 4 3 
    4 5 3 
    
    输出样例#1: 复制
    15 
    

    说明

    感谢@用户名已存在1 提供翻译

    #include<cstdio> 
    #include<iostream>
    #include<cstring>
    #define ll long long
    using namespace std;
    
    const int maxn = 1e5+10;
    
    ll head[maxn],n,val[maxn],tot[maxn],f[maxn],dp[maxn],cnt,ans,size;
    
    struct edge{
        ll v,nex,w;
    }e[maxn<<1];
    
    void adde(ll u,ll v,ll w){
        e[size].v=v;e[size].w=w;e[size].nex=head[u];head[u]=size++;
    }
    
    void dfs(ll u,ll fa){
        tot[u]=val[u];
        for(ll i=head[u];~i;i=e[i].nex){
            ll v=e[i].v;if(v==fa) continue;
            dfs(v,u);
            tot[u]+=tot[v];
            f[u]+=f[v]+tot[v]*e[i].w;
        }
    }
    
    void dfs2(int u,int fa){
        for(ll i=head[u];~i;i=e[i].nex){
            ll v=e[i].v;
            if(v==fa) continue;
            dp[v]=dp[u]-tot[v]*e[i].w+(cnt-tot[v])*e[i].w;
            ans=min(ans,dp[v]);
            dfs2(v,u);
        }
    }
    
    int main(){
        scanf("%lld",&n);
        memset(head,-1,sizeof(head));
        for(ll i=1;i<=n;i++) scanf("%lld",val+i),cnt+=val[i];
        for(ll i=1;i<n;i++) {
            ll u,v,w;scanf("%lld%lld%lld",&u,&v,&w);
            adde(u,v,w);adde(v,u,w);    
        }
        dfs(1,-1);
        ans=f[1];dp[1]=f[1];
        dfs2(1,-1);
        printf("%lld",ans);
        return 0;
    }
    View Code
  • 相关阅读:
    C# 类库 嵌入其他Dll
    docker使用
    7DTD Server Manage
    Eclipse 快捷键-常用
    android webview
    手机摄像头拍摄的照片上传(js .net)
    .net执行存储过程慢,直接执行存储过程很快
    ASP.Net回送。数据提交另外页面
    Mysql详解--知识整理
    IDEA 运行Junit一直卡在Resolving Maven Dependencies
  • 原文地址:https://www.cnblogs.com/plysc/p/10584797.html
Copyright © 2011-2022 走看看