zoukankan      html  css  js  c++  java
  • UVA 414 Machined Surfaces

    Machined Surfaces 

    An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

    A digital image is composed of the two characters, "X" and " " (space). There are always 25 columns to an image, but the number of rows, N, is variable. Column one (1) will always have an "X" in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous X's.

    Similarly, column 25 will always have an "X" in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous X's.

    Digital-Image View of Surfaces

     
    		 Left     		                           Right
    

    XXXX XXXXX tex2html_wrap_inline50

    XXX XXXXXXX

    XXXXX XXXX

    XX XXXXXX

    . .

    . .

    . .

    XXXX XXXX

    XXX XXXXXX tex2html_wrap_inline52

    tex2html_wrap_inline54 tex2html_wrap_inline56

    1 25

    In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank region in any row.

    For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains between the left and right surfaces after theyhave been brought into contact.

    The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost "X" of the left surface of some row is immediately to the left of the leftmost "X" of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

    Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

    Input

    The input consists of a series of digital images. Each image data set has the following format:

    First line -
    A single unsigned integer, N, with value greater than zero (0) and less than 13. The first digit of N will be the first character on a line.
    Next N lines -
    Each line has exactly 25 characters; one or more X's, then zero or more spaces, then one or more X's.

    The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

    Output

    For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

    Sample Input (character "B" for ease of reading. The actual input file will use the ASCII-space character, not "B").

    4
    XXXXBBBBBBBBBBBBBBBBXXXXX
    XXXBBBBBBBBBBBBBBBXXXXXXX
    XXXXXBBBBBBBBBBBBBBBBXXXX
    XXBBBBBBBBBBBBBBBBBXXXXXX
    2
    XXXXXXXXXXXXXXXXXXXXXXXXX
    XXXXXXXXXXXXXXXXXXXXXXXXX
    1
    XXXXXXXXXBBBBBBBBBBBBBBXX
    0

    Sample Output

    4
    0
    0
    题目大意:给t行字符串,统计出共有多少空格(样例中的“B”),和每行有多少空格,然后用总的空格数减去行最少的空格数。
    注意:样例中给的是B,但是在判断的时候要把B换成空格。。。
    UVA的英文真难看懂。太难看懂了。。。。。
    【code】
     1 #include<stdio.h>
     2 int main()
     3 {
     4     char c;
     5     int t;
     6     while(~scanf("%d",&t))
     7     {
     8         if(t==0)
     9             break;
    10         getchar();
    11         int i,j;
    12         int sum=0,min1=10000,min2;
    13         for(i=0;i<t;i++)
    14         {
    15             min2=0;
    16             while(1)
    17             {
    18                 scanf("%c",&c);
    19                 if(c==' ')
    20                 {
    21                     sum++;
    22                     min2++;
    23                 }
    24                 else if(c=='\n')
    25                     break;
    26             }
    27             min1=min1>min2?min2:min1;
    28         }
    29         printf("%d\n",sum-min1*t);
    30     }
    31     return 0;
    32 }
  • 相关阅读:
    博客园二号地址:
    VisionMaster4.0.0二次开发教程(每日更新博客)
    5.观察者模式
    4.策略模式
    微信小程序radio的样式修改
    Linux下mysql安装
    idea2020 设置Run Dashboard
    一个方便统计页面 PV/UV、触发和交互的轻量级前端埋点工具
    登录认证-实名认证-产品设计
    启示录—产品经理
  • 原文地址:https://www.cnblogs.com/pony1993/p/2435672.html
Copyright © 2011-2022 走看看