zoukankan      html  css  js  c++  java
  • POJ3615 Cow Hurdles

    Cow Hurdles
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 4584Accepted: 1990

    Description

    Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

    Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

    The cows' practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

    The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.
     

    Input

    * Line 1: Three space-separated integers: NM, and T
    * Lines 2..M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi 
    * Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

    Output

    * Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

    Sample Input

    5 6 3
    1 2 12 
    3 2 8 
    1 3 5 
    2 5 3 
    3 4 4 
    2 4 8 
    3 4 
    1 2 
    5 1

    Sample Output

    -1

    Source


    这是省赛前的测试赛的一道题目,当时认为应该按搜索做,没做出来,今天看了一下数据结构书,看到了Floyed算法,突然就想起来了这道题。很裸的一个Floyed。

     1 #include <stdio.h>
     2 #include <stdlib.h>
     3 long map[310][310];
     4 int main()
     5 {
     6     int a,b,n,m,t,i,j,k;
     7     long c;
     8     scanf("%d%d%d",&n,&m,&t);
     9     for(i=0;i<=n;i++)
    10         for(j=0;j<=n;j++)
    11             map[i][j]=1000000;
    12     for(i=0;i<m;i++)
    13     {
    14         scanf("%d%d%ld",&a,&b,&c);
    15         map[a][b]=c;
    16     }
    17     for(k=1;k<=n;k++)
    18         for(i=1;i<=n;i++)
    19             for(j=1;j<=n;j++)
    20             {
    21                 c=map[i][k]>map[k][j]?map[i][k]:map[k][j];
    22                 map[i][j]=map[i][j]>c?c:map[i][j];
    23             }
    24     for(i=0;i<t;i++)
    25     {
    26         scanf("%d%d",&a,&b);
    27         if(map[a][b]<1000000)
    28             printf("%ld\n",map[a][b]);
    29         else
    30             puts("-1");
    31     }
    32     return 0;
    33 }

  • 相关阅读:
    将log4Net记录的日志导入数据库操作指南
    算法40 leetcode 155.最小栈
    c++求以3为底的对数 遇到243 怎么也通不过
    算法36 动规初探&&斐波那契&&尾递归
    算法38 5. 最长回文子串
    算法39 leetcode22. 括号生成
    算法34 堆排序heapsort
    算法37 动规求数组和
    算法35 力扣twosum
    c++ vector size()18446744073709551615 bug
  • 原文地址:https://www.cnblogs.com/pony1993/p/2518562.html
Copyright © 2011-2022 走看看