zoukankan      html  css  js  c++  java
  • HDOJ1010 (DFS+奇偶剪枝)

    Tempter of the Bone

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 107043    Accepted Submission(s): 29107


    Problem Description
    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
     
    Input
    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter; 
    'S': the start point of the doggie; 
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
     
    Output
    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
     
    Sample Input
    4 4 5
    S.X.
    ..X.
    ..XD
    ....
    3 4 5
    S.X.
    ..X.
    ...D
    0 0 0
     
    Sample Output
    NO
    YES
    思路:奇偶剪枝,见代码。
    注意:这题最好用cin输入。
    #include <iostream>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    const int MAXN=10;
    int n,m,T;
    char mz[MAXN][MAXN];
    int vis[MAXN][MAXN];
    int sy,sx,gy,gx;
    int dy[4]={0,1,0,-1};
    int dx[4]={1,0,-1,0};
    bool dfs(int y,int x,int step)
    {
        if(y==gy&&x==gx&&step==T)
        {
            return true;
        }
        int rem=T-step;
        int need=abs(y-gy)+abs(x-gx);
        if(rem<need||(rem-need)%2!=0)//奇偶剪枝:迂回,若能到达终点,那么至少所需的步数与还剩余的步数奇偶性相同 
        {
            return false;
        }
        for(int i=0;i<4;i++)
        {
            int ny=y+dy[i];
            int nx=x+dx[i];
            if(0<=ny&&ny<n&&0<=nx&&nx<m&&mz[ny][nx]!='X')
            {
                if(!vis[ny][nx])
                {
                    vis[ny][nx]=1;
                    if(dfs(ny,nx,step+1))
                    {
                        return true;
                    }
                    vis[ny][nx]=0;
                }    
            }
        }
        return false;
    }
    int main()
    {
        while(cin>>n>>m>>T&&(n+m+T)!=0)
        {
            memset(vis,0,sizeof(vis));
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<m;j++)
                {
                    cin>>mz[i][j];
                    if(mz[i][j]=='S')
                    {
                        sy=i;
                        sx=j;
                    }
                    else if(mz[i][j]=='D')
                    {
                        gy=i;
                        gx=j;
                    }
                }
            }
            vis[sy][sx]=1;
            if(dfs(sy,sx,0))
            {
                cout<<"YES"<<endl;
            }
            else
            {
                cout<<"NO"<<endl;    
            }
        }
        return 0;
    }
     
  • 相关阅读:
    【UML九种图系列】之用例图
    数据结构之后缀数组
    Web Service实例——天气预报
    庞果网 合法字符串
    web 版发送邮件-已删除
    C语言实现双向链表删除节点、插入节点、双向输出等操作
    [置顶] String StringBuffer StringBuilder的区别剖析
    N!末尾有多少个零
    细说业务逻辑 -- 丢失的业务逻辑层
    你真的了解分层架构吗?——写给被PetShop"毒害"的朋友们
  • 原文地址:https://www.cnblogs.com/program-ccc/p/4679763.html
Copyright © 2011-2022 走看看