zoukankan      html  css  js  c++  java
  • POJ2823(优先队列)

    Sliding Window
    Time Limit: 12000MS   Memory Limit: 65536K
    Total Submissions: 50738   Accepted: 14590
    Case Time Limit: 5000MS

    Description

    An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
    The array is [1 3 -1 -3 5 3 6 7], and k is 3.
    Window positionMinimum valueMaximum value
    [1  3  -1] -3  5  3  6  7  -1 3
     1 [3  -1  -3] 5  3  6  7  -3 3
     1  3 [-1  -3  5] 3  6  7  -3 5
     1  3  -1 [-3  5  3] 6  7  -3 5
     1  3  -1  -3 [5  3  6] 7  3 6
     1  3  -1  -3  5 [3  6  7] 3 7

    Your task is to determine the maximum and minimum values in the sliding window at each position. 

    Input

    The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

    Output

    There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

    Sample Input

    8 3
    1 3 -1 -3 5 3 6 7
    

    Sample Output

    -1 -3 -3 -3 3 3
    3 3 5 5 6 7
    #include"cstdio"
    #include"cstring"
    #include"queue"
    #include"vector"
    using namespace std;
    const int MAXN=1000005;
    int a[MAXN];
    int Min[MAXN];
    int Max[MAXN];
    int n,k;
    int cnt;
    struct comp1{
        bool operator()(const int x,const int y)
        {
            return a[x] > a[y];
        }
    };
    struct comp2{
        bool operator()(const int x,const int y)
        {
            return a[x] < a[y];
        }
    };
    priority_queue<int,vector<int>,comp1> que1;
    priority_queue<int,vector<int>,comp2> que2;
    int main()
    {
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=k;i++)
        {
            que1.push(i);
            que2.push(i);
        }
        Min[cnt]=a[que1.top()];
        Max[cnt]=a[que2.top()];
        cnt++;
        for(int i=k+1;i<=n;i++)
        { 
            que1.push(i);
            que2.push(i);
            while(i-que1.top()>=k)    que1.pop();// 将窗口之外的删除
            Min[cnt]=a[que1.top()];
            while(i-que2.top()>=k)    que2.pop();
            Max[cnt]=a[que2.top()];
            cnt++;
        }
        for(int i=0;i<cnt;i++)
            printf("%d%c",Min[i],(i==cnt-1)?'
    ':' ');
        for(int i=0;i<cnt;i++)
            printf("%d%c",Max[i],(i==cnt-1)?'
    ':' ');
        return 0;
    }
  • 相关阅读:
    python之scrapy篇(三)
    python之scrapy篇(二)
    python之scrapy篇(一)
    matlib调用python时转py格式为matlib格式
    ubuntu18.40 rtx2080ti安装显卡驱动/cuda/cudnn/tensorflow-gpu
    pytorch导入错误so: undefined symbol: _Z11libshm_initPKc
    yolo_v3训练自己的模型(人脸及deep-sort)(或自己数据集)
    python-图像处理(映射变换)
    python编译pyc工程--导包问题解决
    python(leetcode)-14最长公共前缀
  • 原文地址:https://www.cnblogs.com/program-ccc/p/5185626.html
Copyright © 2011-2022 走看看