zoukankan      html  css  js  c++  java
  • POJ1365:质因数分解

    Prime Land
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 3590   Accepted: 1623

    Description 

    Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers ekx, ekx-1, ..., e1, e0, (ekx > 0), that  The sequence 

    (ekx, ekx-1, ... ,e1, e0



    is considered to be the representation of x in prime base number system. 

    It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple. 

    Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''. 

    Help people in the Prime Land and write a corresponding program. 

    For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi. 

    Input

    The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.

    Output

    The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.

    Sample Input

    17 1
    5 1 2 1
    509 1 59 1
    0

    Sample Output

    2 4
    3 2
    13 1 11 1 7 1 5 1 3 1 2 1

    举例理解题意:例2:将 进行质因数分解,结果为3^2。
    思路:筛选素数打表,由小到大分解。
    #include <iostream>
    #include <cstring>
    using namespace std;
    const int MAXN=33000;
    bool isPrime[MAXN];
    int prime[MAXN],top;
    void sieve()
    {
        memset(isPrime,true,sizeof(isPrime));
        isPrime[0]=false;
        isPrime[1]=false;
        for(int i=2;i<MAXN;i++)
        {
            if(isPrime[i])
            {
                prime[top++]=i;
                for(int j=i+i;j<MAXN;j+=i)
                {
                    isPrime[j]=false;
                }
            }
        }
    }
    int multiply(int x,int n)
    {
        int mul=1;
        for(int i=1;i<=n;i++)
        {
            mul*=x;
        }
        return mul;
    }
    int methods[MAXN];
    void solve(int x)
    {
        memset(methods,0,sizeof(methods));
        int l=0;
        while(x!=1)
        {
            if(x%prime[l]==0)
            {
                methods[prime[l]]++;
                x/=prime[l];
            }
            else l++;
        }
    }
    int main()
    {
        int x,n;
        sieve();
        while(cin>>x&&x!=0)
        {
            int sum=1;
            cin>>n;
            sum*=multiply(x,n);
            while(cin.get()!='
    ')
            {
                cin>>x>>n;
                sum*=multiply(x,n);
            }
            sum--;
            solve(sum);
            for(int i=top;i>=0;i--)
            {
                if(methods[prime[i]]!=0)
                {
                    cout<<prime[i]<<" "<<methods[prime[i]]<<" ";
                }
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    index unique scan 与index range scan等的区别
    oracle创建表空间
    能使Oracle索引失效的七大限制条件
    优化 : Oracle数据库Where条件执行顺序 及Where子句的条件顺序对性能的影响
    easy-rules
    token
    同步,异步
    String、StringBuilder、StringBuffer
    分区表
    jvm内存模型
  • 原文地址:https://www.cnblogs.com/program-ccc/p/5641298.html
Copyright © 2011-2022 走看看