zoukankan      html  css  js  c++  java
  • POJ1063Cable master(二分搜索)

    Cable master
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 36288   Accepted: 7743

    Description

    Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
    To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
    The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
    You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

    Input

    The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

    Output

    Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
    If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

    Sample Input

    4 11
    8.02
    7.43
    4.57
    5.39

    Sample Output

    2.00
    #include <iostream>
    #include <math.h>
    #include <iomanip>
    using namespace std;
    const int MAXN=10005;
    const double ESP=1.0e-6;
    int n,k;
    double cab[MAXN];
    double test(double l)
    {
        int s=0;
        for(int i=0;i<n;i++)
        {
            s+=(int)(cab[i]/l);
        }
        return s>=k;
    }
    int main()
    {
        while(cin>>n>>k)
        {
            for(int i=0;i<n;i++)    
            {
                cin>>cab[i];
            }
            double l=0.0;
            double r=100000000.0;
            while(fabs(r-l)>ESP)
            {
                double mid=(l+r)/2;
                if(test(mid))    l=mid;
                else r=mid;
            }
            double res=floor(r*100)/100.0;
            cout<<showpoint<<setprecision(2)<<fixed<<res<<endl;
        }
        return 0;
    }
  • 相关阅读:
    monkey事件简介
    Monkey简介
    Package与Activity简介
    adb 命令
    安卓模拟器简介
    iis重启的几种方法
    window下安装FTP服务器
    防止dedecms注入文件挂马的解决方法
    织梦漏洞可疑PHP文件/article文件夹
    织梦Dedecms系统可疑文件include/filter.inc.php扫描出漏洞,该如何解决?
  • 原文地址:https://www.cnblogs.com/program-ccc/p/5677881.html
Copyright © 2011-2022 走看看